It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
bootx: Enabling VSync in my GPU control panel solved the issue completely. Just enabling it in-game won't work if your GPU settings are forcing it off.
Thanks, I'll try that then. Gave up on the game a while ago, though.
avatar
bootx: VSync
Ok. I have something to tell you...

IT WORKS! It finally works.

But for some reason, the game didn't want to start. So I re-installed it but that didn't work either. Then I found a thread about the game not starting because the address to the game's folder might be too long. So I shortened the name.

Turns out that was the issue. Now it works with DirectX7, The widescreen fix and everything. The only question is if I can install a graphic mod if I already have a savefile. And how.
That, I do not know.
It is an old thread by feel like I should contribute since I started having the same problem recently.
It started in Arnika when new characters joined my party. It was very annoying, but I found a - working for me - workaround.
Double tapping movement key, or moving forward in a direction you were moving before keys stopped responding - like you would like to preserve momentum, seems to work. It is strange tho.

Also, after alt-tabbing I had problem where my keyboard did not respond, and mouse worked fine. It is not a problem described here, but similar, all you have to do is alt + enter to fullscreen (even tho it looks like it is fullscreen) and it will work again fine.
avatar
NoirBG: It is an old thread by feel like I should contribute since I started having the same problem recently.
It started in Arnika when new characters joined my party. It was very annoying, but I found a - working for me - workaround.
Double tapping movement key, or moving forward in a direction you were moving before keys stopped responding - like you would like to preserve momentum, seems to work. It is strange tho.

Also, after alt-tabbing I had problem where my keyboard did not respond, and mouse worked fine. It is not a problem described here, but similar, all you have to do is alt + enter to fullscreen (even tho it looks like it is fullscreen) and it will work again fine.
Bumping this old thread to confirm that it is not just "VSync" that you need enable - but specifically, that the game's movement bugs out if you run it above 60 FPS.

So to fix this issue, you'd need to set your high-refreshrate monitor's refreshrate down - or use an FPS limiter of some sort, like the Rivatuner Statistics Server one, set to cap it at 60 FPS.

I've also found that you can run the game windowed in Glide mode by using dgVoodoo2 and configuring it to do so instead of using nGlide. I'm not sure if you can have said window centered, though.
Post edited April 20, 2018 by Bloax
avatar
bootx: VSync
avatar
Trapster: Ok. I have something to tell you...

IT WORKS! It finally works.

But for some reason, the game didn't want to start. So I re-installed it but that didn't work either. Then I found a thread about the game not starting because the address to the game's folder might be too long. So I shortened the name.

Turns out that was the issue. Now it works with DirectX7, The widescreen fix and everything. The only question is if I can install a graphic mod if I already have a savefile. And how.
Hello.
Just to bump up this post, as this solved the issue to me as well.
AMD user here; changed the "Wait for Vertical Refresh" from Enchanced Sync to Always on (I haven't tested the other options, though).
To any of you reading this in 2019... here is a screenshot:
https://imgur.com/a/rxlP1

Cheers!
Post edited July 18, 2019 by pyckles
Well it certainly is nice to bump up this post and keep up the VSync line of speech, while the actual issue is that movement bugs out if the game runs above 60 FPS - and thus VSync will fix absolutely nothing unless your monitor is set to 60 Hz ; )

So to reiterate my post at the end of the last page for any lazybones who missed it in 2019, solving this issue consistently requires using a framerate limiter of any kind set to cap it at 60.

Those come in various flavours, but Rivatuner Statistics Server tends to do an excellent job.
A solution for a number of issues on modern systems is to use the Wizardry 8 Extender. Gives support for widescreen resolutions, and actually improves performance in various ways. It can be found here: [url=]https://pcgamingwiki.com/wiki/Wizardry_8#Widescreen_resolution[/url]

It even helps improve the speed that you can open the map, as useful as it may or may not always be.
Can confirm this worked for me as well. The AMD Vsync setting and keeping my monitor at 60 Hz. This game is worth the effort to make it work properly!



avatar
Trapster: Ok. I have something to tell you...



IT WORKS! It finally works.

But for some reason, the game didn't want to start. So I re-installed it but that didn't work either. Then I found a thread about the game not starting because the address to the game's folder might be too long. So I shortened the name.

Turns out that was the issue. Now it works with DirectX7, The widescreen fix and everything. The only question is if I can install a graphic mod if I already have a savefile. And how.
avatar
pyckles: Hello.
Just to bump up this post, as this solved the issue to me as well.
AMD user here; changed the "Wait for Vertical Refresh" from Enchanced Sync to Always on (I haven't tested the other options, though).
To any of you reading this in 2019... here is a screenshot:
https://imgur.com/a/rxlP1

Cheers!