It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

After the mission where you protect the Victory while it's escaping from Kilrathi territory, there's a cutscene in which two kilrathi are discussing the escape. The leader says "The emperor must not know of the success of the Terran incursion". While the subordinate is replying with "My thoughts exactly, my liege", the game crashes.

When I run DOSBox through a console, an error message starts rapidly appearing, which says "CDROM: GetTrack at sector 402613 is outside the playable range", then "SBPRO1: DSP was reset".

I reinstalled the game (and played through all of it to that point again because I did not back up my save), and changed SoundBlaster Pro to SoundBlaster 16 (both in my .conf file and in the game's installer), but the problem persisted. This time, though, the cutscene noticeably slowed down and began to stutter before the crash. I haven't yet recorded the error messages I'd get from this configuration because I have to play through the mission again.

On my first configuration, though, I skipped past this cutscene and was able to continue. However, every single cutscene would lead to a crash, from the argument between Hobbes and Cobra on the flight deck, to the briefing screen, making further progress impossible.

I suspect that these crashes are a result of the game requiring a disk swap before the Ariel System levels begin; something is wrong with the way GOG has mounted the disks, and so the game cannot properly access the FMV cutscenes after a certain point (previous cutscenes proceeding the disk change worked perfectly - maybe these cutscenes are still stored on the first disk? Unlikely; perhaps memory just runs out after a certain point and the second disk can't be read besides the first few cutscenes and missions).

I've search and searched but nobody else seems to have encountered this issue. Has anyone got a clue?
No posts in this topic were marked as the solution yet. If you can help, add your reply
No progress on fixing this so far. However, I did discover an error message produced by the game itself by running DOSBox directly, rather than through the conf file. It reads as follows:

MovieIFF::read() Failure.

This error is probably the result of a bad CD-ROM read.
Please try running the game again from your latest save
game and the problem should go away. If the problem
persists, you may have a bad CD. If you continue to have trouble,
please call Origin Customer Service for more information.

I'm playing this game on Linux, but, seeing as GOG has packaged this game in an extremely shoddy manner overall, I had to install the Windows version through WINE, then take the DOS files and use them in my own version of dosbox-staging. It's not the version of DOSBox that's causing the issue, because I've tried several different versions. I suspect that the files have come out corrupted from the WINE installer. I've never had this experience before, despite using this method to install several DOS games from GOG, but I suppose it's possible (against all odds, considering I reinstalled the game twice), and it would explain why nobody else seems to have had this issue. I'll try to track down some other copy of this game and report the results.

Okay, it was an easy fix in the end. All I did was extract the data.dat file into the main directory and made the appropriate changes to the configuration file. I'm just going to do that for all GOG releases from now on; this compressing all the data into an iso or dat file is really just fucking nonsense.
Post edited November 05, 2022 by BillyTyphoid
Had the same problem, thanks for sharing your solution!

For others encountering the same problem, extract the .dat file (it is an ISO) to a new directory and change your dosbox configuration to include this directory (instead of the .dat file), i.e.:

mount d "/home/<your_user>/Games/gog/wing-commander-iii-heart-of-the-tiger/extractediso" -t cdrom

I installed via Lutris, in that case you can change the line above in dosboxWC3_lutris.conf.