It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
For everyone who is stuck with the dosbox version here are a few tips. I highly recomend changing the following in the dosbox_privateer2.conf for dosbox in the game directory.

[sdl]
output=OpenGL (altho this may be different with your system and you just need to mess around until you find whats best)

[cpu]
cycles=max (this will make your planet animations fast and shouldn't affect gameplay although you may get more humor)

[render]
aspect=false (this should help with the videos a bit)

After those changes run the game and get to space. Once there hit ALT+O to open the options. you may get joystick calibration just skip it and turn off high detail level. now fly around. you should have much less stutter when facing large objects. its not a fix and there is no way to fully remove stutter from this game without changing to the windows based version. Hope this helps.
We could fix this slowdown entirely IF the game didn't crash on videos when using dynamic core...
avatar
Baggins: I say we keep petitioning them and let them know directly. They have given alternate versions in the past for support with enough requests. Send in tickets and let them know about the fan patches.
Doing it first thing tomorrow! :D
I'm having similar problems, slow down when objects are on screen, also, some of the key bindings aren't working correctly. Most annoyingly, the gamma adjust with + and - for cuts scenes only works to decrease the brightness and the video becomes unwatchable. I hope that GOG patches this soon, I was really looking forward to Privateer 2 and nearly jumped out of me chair when I found out the GOG finally had it up, and it would be a shame if it were to remain in a less than satisfactory state.
Post edited September 20, 2013 by matthewageroge
alright. seams changing the sound settings for the game to soundblaster will allow the game to run with cputype set to auto or dynamic and that seams to fix most of the slowdown and make the dosbox version playable. I can confirm this works for boxer in mac osx as well.
avatar
jacknozwad: alright. seams changing the sound settings for the game to soundblaster will allow the game to run with cputype set to auto or dynamic and that seams to fix most of the slowdown and make the dosbox version playable. I can confirm this works for boxer in mac osx as well.
I do confirm it works. Hit 'Launch Settings' in the 'Privateer 2' directory and change the 'digital audio' to Sound Blaster or Sound Blaster Pro. Once changed, you can set cpu core to dynamic and the game won't crash. No low frame rates anymore. Thank you jacknozwad!
tried this and its a no go for me. Game slows down around planets and near ships :/
avatar
lagnad: tried this and its a no go for me. Game slows down around planets and near ships :/
Have you tried to use following settings in 'dosbox_privateer2' file?
core=dynamic
cputype=pentium_slow
cycles=auto

you can also get some extra frames by using output=opengl
Nevermind my previous post. must have forgotten one of the values. retried and now it seems to work.
avatar
jacknozwad: alright. seams changing the sound settings for the game to soundblaster will allow the game to run with cputype set to auto or dynamic and that seams to fix most of the slowdown and make the dosbox version playable. I can confirm this works for boxer in mac osx as well.
avatar
ra100: I do confirm it works. Hit 'Launch Settings' in the 'Privateer 2' directory and change the 'digital audio' to Sound Blaster or Sound Blaster Pro. Once changed, you can set cpu core to dynamic and the game won't crash. No low frame rates anymore. Thank you jacknozwad!
I do think on my machine the game runs a bit faster than normal but its actually a bit more fun I think.

For anyone trying to do run this in boxer on a Mac run setsound.exe to change the sound card settings then just check Optimize for newer games checkbox and slide cpu speed to MAX in the CPU Inspector window. For better videos make sure Boxer isnt set to use 4x3 aspect ratio in the view dropdown or hit (Shift+Command+A) this has the added benefit in full screen on a wide screen monitor of running videos on my 16:10 monitor in full screen. Game will always be 4x3 no matter what. If you have a crash when trying to skip videos make sure the setsound settings saved.
Post edited September 24, 2013 by jacknozwad
I'm using:

core=dynamic
cputype=pentium_slow
cycles=auto

But now the framerate is way too fast! Is there anyway to slow it down about 25%?

avatar
ra100: I do confirm it works. Hit 'Launch Settings' in the 'Privateer 2' directory and change the 'digital audio' to Sound Blaster or Sound Blaster Pro. Once changed, you can set cpu core to dynamic and the game won't crash. No low frame rates anymore. Thank you jacknozwad!
avatar
jacknozwad: I do think on my machine the game runs a bit faster than normal but its actually a bit more fun I think.

For anyone trying to do run this in boxer on a Mac run setsound.exe to change the sound card settings then just check Optimize for newer games checkbox and slide cpu speed to MAX in the CPU Inspector window. For better videos make sure Boxer isnt set to use 4x3 aspect ratio in the view dropdown or hit (Shift+Command+A) this has the added benefit in full screen on a wide screen monitor of running videos on my 16:10 monitor in full screen. Game will always be 4x3 no matter what. If you have a crash when trying to skip videos make sure the setsound settings saved.
Post edited September 29, 2014 by wagstaff21