It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Well - here I am having problems with keyboard mapping again! I used the DOSBOX mapper to effectively map several of the Privateer keyboard commands to my Thrustmaster HOTAS X. Worked well . Finished privateer and moved on to Righteos Fire. Got RF running OK by making a shortcut to target dosboxPriv_RF.conf instead of dosboxPRIV_single.conf - but all my keyboard mapping has *gone* - not only that, if I run the mapper under Righteous Fire it refuses to recognise my Thrustmaster - just implements the basic joystick - Can't map any keys. I think that maybe for some reason the other .conf file - dosboxPRIV.conf that contains all the game specific settings may be being ignored when I go to Righteous Fire resulting in the Thrustmaster not being properly recognised - but can't see a way of forcing it.

Has anyone else encountered this problem? - and solved it? Very frustrating as I had a sweet setup in Privateer using the mapped HOTAS and a LOgitech keypad for additional in-flight commands.

Any insight and advice much appreciated
No posts in this topic were marked as the solution yet. If you can help, add your reply
Make a copy of DosboxPRIV.conf and edit the [autoexec] field so it launches Righteous Fire instead (priv.exe r instead of priv.exe) then call that with your launcher.
Alternatively you can point mapperfile= to the .map file you used for Privateer and use the same for Righteous Fire.
Thanks for these suggestions - I will give them both a try :)
Cracked it! - I checked all the .conf files and everything was in order - so that wasn't the problem - but then I noticed that the <joystick> line was set to auto - this had worked perfectly well for my Thrustmaster HotasX in Privateer but I experimentally changed it to <joystick -fcs> (the GOG default thrustmaster setting) - and all was well :)