It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'll try later today, but just bought Samurai 4 and DLC and trying to download.

Everything is downloading fine except the 4G "main" file (the second part of the DL). It keeps failing when I try to save it, but if I click the link and don't hit anything I get this error message:

C:\Users\....\Local\Temp\3ApR0p0L.bin.part could not be saved, because the source file could not be read.

Is this just me? If so, what can I do to fix this besides just wait until it works? :P
Post edited July 26, 2018 by whatsnottaken
No posts in this topic were marked as the solution yet. If you can help, add your reply
on google chrome every time it says fail keep clicking "resume" until it finish downloading .

hope you have a fast internet speed or you`ll be clicking "resume" a lot.

I download from the offline backup game installers.
I sent a support ticket, but just ended up installing Galaxy specifically to download this. Uninstalled galaxy afterward and everything worked fine, but I never did get the standalone to download.

I definitely prefer the old school installers, but this is the only time I had to use a workaround so I can excuse the problem, still no idea what it was though. :P