It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello there,
I wanted to ask if there's some way to disable the heaviest particle effects in the game (dev console, config file, something). I get it that Unity-based stuff (which Mechanicus seems to be, if I'm not mistaken) all suffer from some performance issues (hey, my PC gobbles up more than 300 W at peaks!, even TW:Warhammer was less demanding), but I get solid 60 fps the whole time unless I play on a particle-heavy map.