It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hey all

I just managed to get the game working on my ASUS laptop! And I was very simple but took me all day to find it out.
This fix also works for laptop users having issues with two GPUs (in my case, it was the RX Vega 10 and the Nvidia GTX 1650).

So, Vulkan would not recognize the RX Vega 10, and the game would not launch, because of the 'Vulkan error'. So I wanted the game to launch with my GTX 1650. The way to do it was with the Nvidia control panel, on 'Manage 3D Settings', then 'Program Settings', and then you choose the .exe from the game and select 'High-performance NVIDIA processor' as preferred graphics processor. Ok, but Gladius never showed up on the list, and trying to add it would not work.

So after much researching, I found out that the Nvidia control panel would not add the .exe if the main file had a comma on the directory name.

So I went to where my game was installed, "C:\GOG Galaxy\Games\Warhammer 40,000 Gladius - Relics of War'', and renamed the folder to: "Warhammer 40000 Gladius - Relics of War".

Next step, I added the .exe called 'Gladius' to the Nvidia control panel, and it worked!

After that, I renamed the game's folder back to the original name with the comma.

And yes, It worked! I have been playing it for the last couple of hours and enjoying it a lot.

Sounds easy, and somewhat strange, but I found out that a lot of people were having the same issue and I decided to share.

Really hope this helps!
well done but you may also want to install English uk [or US] language pack
ussnorway: well done but you may also want to install English uk [or US] language pack
Where can I find this language pack? Google is useless. Please help
Oh, I though it was a language pack for the game!

Thank you