It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Is there a way to disable it? Maybe it's not mouse acceleration, but the mouse sensitivity is just... weird.
Looked through the folders for setting but a lot of it's coded so no luck best you can do is adjust mouse setting externally to combat the acceleration.