It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I had success installing Gravis for a different game. Those same methods do not seem to work for this game.

I currently have the most up to date version of DOSBox installed.

I copied the ULTRASND folder into the game directory "C:\Program Files (x86)\GOG Galaxy\Games\Warcraft Orcs & Humans". I changed the dosbox_warcraft.conf file so that Gravis Ultrasound should be enabled.



When I run setup.exe (by dragging it onto dosbox.exe) and I try to enable Gravis Ultrasound I get a message saying, "The 'ULTRASND' environment variable has not been set. Please install the Gravis drivers and then run SETUP."

EDIT: I was able to successfully configure the sound by launching the game through the GOG Galaxy. However, as with the previous game, I am unable to get these settings to work if I launch the game through dosbox.exe rather than GOG Galaxy. I suspect this has something to do with setting up DOSBox to mount the correct drives.
gus.png (12 Kb)
Post edited May 20, 2021 by Corvus_Brachy
This question / problem has been solved by Linksimage
EDIT: Ninja'ed while testing it myself :P

Try running the setup from the GOG shortcut. When drag-and-droping SETUP.EXE onto the DOSBox exec you are not using the Warcraft .conf file but all default settings.


In order to use the GOG installation modifying as little as possible, you need to:

1) Edit the dosbox_warcraft.conf file changing the line that says gus=false to gus=true

2) Copy (could also make a junction of, or hard-link) your ULTRASND dir to the base directory of the GOG installation (the one with WAR.EXE).

3) Run the game setup, by pressing 2 at the menu that appears when you run the default GOG created shortcut. Select Gravis Ultrasound for digitized sound card and/or music sound card. The setup program will detect the port and DMA settings automatically (differently than with SB). Then select Save settings and exit.

4) Run the game and check that both sounds and music are working. You will probably have to adjust the volume levels from the F10 menu in-game. The music sounds much louder at the default value with the GUS than with GenMIDI or SB16.

5) Enjoy!


If you have or are planning to add more old games to your collection, I recommend you look into using a DOSBox frontend such as DBGL (, and put all your game dirs (and ULTRASND) in a single directory that you mount as C: for all of them.
Post edited May 20, 2021 by Links
Thanks so much! I'll keep this in mind when setting up other games for DOSBox.