It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Some of the cutscenes of the battlenet edition were different from the original DOS. I remember, in particular, the orc ending where they sack Lordaeron has particularly awful looking animations with the catapults, King Terenas and his guards (whose weapons are missing in that version), etc.

Or does this just purely use all of the scenes?
This question / problem has been solved by QWEEDDYZimage
That release have no change after Bnet version. Orcs outro seems exactly like you say.
Found and saw both variants right now. Waaay different sequences!

Well, i always prefer Tides of Darkness for original campaign. And The Dark Saga for expansion...
Post edited April 06, 2019 by QWEEDDYZ
Im not solved this. And I'm not going to do that. Yeah, i have only Bnet CD and too lazy for search-downloading original DOS each time i want play... but i recommend this for any other.

Also, i play original RoC campaigns in Reign of Chaos CD with only first two updates. And even TFT from CD version (1.07) without patches, cause in 1.10 and later video play in different way. Editing regedit and updating codec packs do not solve this for 100%. "Out of the box" v.1.07 (without amount of codec;s in Windows) play much better for me.
Post edited April 07, 2019 by QWEEDDYZ
Hey, in what way are the cutscenes different in Warcraft 3 and TFT from 1.10 and later? How so?
They same, but work different - on same machine with same codecs installed (from indeo and microsoft only). Patched version requires reg.editing (do not changed too much for me) and codecs (at least C.C.C.P or even K-Lite codec pack - im not sure).

Video folder (mpq files) nver changed (i check in Total Commander) and played normally (without codecs) if you open MPQ file as media file in MPC-HC\VLC\etc. It look in 1.0.7 same as in media player. And worse after 1.10 update.

But i test it long ago. Probably even on Windows Vista (or on Win7). I didnt play Warcraft's on Win8 and do not have Win10.
Google says about cinematicoverrides string in registry. Im not sure what it is.
Post edited August 13, 2019 by QWEEDDYZ