It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I can't progress in the game because I can't get passed the mission Hunt Dvergar which is part of the campaign.. every time I get to 29/30 I go back and look for the one I missed and that one is ALWAYS invulnerable it even says it under its health bar. I tried dying so I could respawn and see if that worked.. but it didn't. Now the enemy is invulnerable and it has no health bar. This is on Xbox one by the way.

UPDATE: Restarted and did the mission all over.. and it worked. Thank goodness. But that was a huge pain to have to do over again.


Turns out Hunt Dvergar is not a mandatory quest on the campaign, it's a hunt map. But every time I go to progress with the story.. it puts me into "Hunt Dvergar" Even though I choose the mission Simul's Lair. (Which I've already done.) What is going on?! I can't progress in the game if this stuff is going to happen. I literally can't get any further in the story.
Post edited May 01, 2017 by Jewleigh
No posts in this topic were marked as the solution yet. If you can help, add your reply