It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I have installed Redemption on Win 10 and every time I try and run it it just displays a black screen and then crashes and closes with the message Vampire.exe has stopped working. I tried as a fresh install and with the Age of Redemption mod and get the same results. Age of Redemption will run in windowed mode but the pre rendered cut scenes have glitched colours and generally don't display correctly. Have also tried all compatibility modes with no success. Any ideas?
No posts in this topic were marked as the solution yet. If you can help, add your reply
In Windows 10, Redemption will run in windowed mode via DDraw virtualization, so when you do get the game running, you may not be able to adjust brightness of the game. Some solutions have been posted on this board with command lines, but none of them have worked for me.

Anyway, the only things I can think of off the top of my head is to delete the masquerade.ini file in the game directory then restarting the game, or perhaps reinstalling the game.

If that doesn't work, try cutting and pasting the bik videos out of the Video folder, to someplace safe, then try to run it. It will help determine if it's a problem with how your computer is working with the bik files with the resolution changes. I'll check back in a day or so.
I have tried deleting the masquerade.ini file, made no difference. I then tried re downloading the setup file and reinstalling (deleting all of the original installation folders, settings and going into the registry to make sure it was completely gone) no difference. I then tried removing all the .bik file from the games folders, no difference and final I even tried replacing the games binkw32.dll file with the one from Bloodlines (to see if the old file was just incompatible with modern computer) and it still crashes every time. Maybe it just won't run on my Windows 10 system but if anyone has any other theories or ideas I would appreciate them.
avatar
thraxman: I have tried deleting the masquerade.ini file, made no difference. I then tried re downloading the setup file and reinstalling (deleting all of the original installation folders, settings and going into the registry to make sure it was completely gone) no difference. I then tried removing all the .bik file from the games folders, no difference and final I even tried replacing the games binkw32.dll file with the one from Bloodlines (to see if the old file was just incompatible with modern computer) and it still crashes every time. Maybe it just won't run on my Windows 10 system but if anyone has any other theories or ideas I would appreciate them.
I don't think it's the binkw32.dll problem, or the game would work by removing the bik files. I'm having trouble thinking of anything else to try, as you seemed to have read through everything in the forum already. The Bloodlines bink file wouldn't work anyway, I believe the Oblivion one works, but reportedly without sound.
So i was dealing with the same issue for a while, and i read the multiple fixes in the forums, and none of them worked for me. But a friend of mine suggested a very weird solution that just happened to work for me.

The solution is this:
Create a shortcut for Vampire.exe and edit the path with a -window at the end, so it should look something like this:

"C:\Program Files (x86)\GOG.com\VtMR\Vampire.exe" -window

For some reason, this was all i needed for it to work again, so hope this works for you guys as well!
avatar
TheDevilChicken: So i was dealing with the same issue for a while, and i read the multiple fixes in the forums, and none of them worked for me. But a friend of mine suggested a very weird solution that just happened to work for me.

The solution is this:
Create a shortcut for Vampire.exe and edit the path with a -window at the end, so it should look something like this:

"C:\Program Files (x86)\GOG.com\VtMR\Vampire.exe" -window

For some reason, this was all i needed for it to work again, so hope this works for you guys as well!
I believe you can add command-line switches to games run through Galaxy 1.2 as well...

It's strange you can't force the game to run through a window with a menu option, even call it a basic "debug" mode or something...

Anyway: I hope it works too!

Edit: I note that +Signothorn has created a helpful video, see the link in his profile!
Post edited May 25, 2019 by grubbyseismic
avatar
TheDevilChicken: So i was dealing with the same issue for a while, and i read the multiple fixes in the forums, and none of them worked for me. But a friend of mine suggested a very weird solution that just happened to work for me.

The solution is this:
Create a shortcut for Vampire.exe and edit the path with a -window at the end, so it should look something like this:

"C:\Program Files (x86)\GOG.com\VtMR\Vampire.exe" -window

For some reason, this was all i needed for it to work again, so hope this works for you guys as well!
avatar
grubbyseismic: I believe you can add command-line switches to games run through Galaxy 1.2 as well...

It's strange you can't force the game to run through a window with a menu option, even call it a basic "debug" mode or something...

Anyway: I hope it works too!

Edit: I note that +Signothorn has created a helpful video, see the link in his profile!
That did the trick. Thank you! It's odd, but I've noticed a lot of compatibility issues with older games can be fixed by using it as a window instead of full screen.