It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Unplayable. POTENTIALLY SOLVED THOUGH!

See below:
I. Description of Issue
II. Thoughts Leading Up to Potential Resolution for Issue
III. What Appeared To Work (if tldr; skip to this)
IV. Post-Mortem: Why "Potentially" and not "Confirmed" Solved?

I. Description of Issue:
----------------------------

Game loads and shows up on one monitor.
But when using mouse controls and I look to far in direction where my other monitor is at, I see my mouse cursor eventually come into view on that other monitor. It mimics the movements I do in the game.

If I click on anything while the cursor is visible in the other monitor, it causes the game screen disengage from the monitor it's own, and show the background deskstop of that monitor.

So whereas the mouse cursor should be invisible, confined to the monitor the game is on, it's not.
Apparently, the game screen is "borderless" and the mouse cusor and end up on another monitor and clicking causes the game to sieze up.

Re-clicking into the game or alt-tabbing loads up a wacked up screen of the game.
The game screen that returns is black with some parts of the HUD and the radar contacts blur.
Can't see but can hear the game.

The only thing at this point is end the program.

Fail.

II. Thoughts Leading Up to Potential Resolution for Issue:
---------------------------------------------

I recall both Uprising 1 and 2 had an option "software mode".
Why is that not an option here?
(I actually preferred the software mode for Uprising 1, it looked great and was smooth, it had a "character" to it, like playing an old Quake game. It was fluid. Uprising 2, however, it's software mode was really fugly! The 3DFX mode was great back then.)

Looking into this, I came to the realization it was all due to the nGlide 3dfx wrapper. It's pretty much being "forced" on the GoG gamer. I noticed in the "readme" for the nglide configurator that came with the GoG installation, had a changelog which mentiond patching cross-cursor issues.

Theory 1: nGlide is flawed as it has this has a known issue
Support 1: went to their forum and found other references to patching this issue
Theory 2: the issue appears to be game specific
Support: the references of fixing the issue in their changelogs refer to fixes for specific games
Counter: one log referred broadly to a fix being implemented
Theory 3: nGlide would need to create a specific fix for Uprising 1 and 2 (as both have this cross cursor mutli-monitor issue)
Theory 4: GoG version of nGlide tool is out of date
Theory 5: Update to the latest version of nGlide
Support: since broad fix to issue was mentioned for version later than one GoG installed

Outcome: failure, issue persists
Theory 6: revisit about software vs. 3dfx mode, is there a configuration launcher or way to toggle?
Outcome: no, it's either disabled or excluded from the installation
Not Used Support: install from copy of disc to see
Note: when installing latest nGlide, it didn't disturb the Uprising 1/2 folders.
Theory 7: what is in those folders could be interferring with latest version running?

III. What Appeared To Work:
----------------------------------------------------

Short answer: removing the glide dlls from the game folders
*it's possible one might just need to remove the glide dlls instead of updating to latest version

*But Long Answer is what I did exactly:

1) *Installed latest version of nGlide (from site of company that makes it, v2.10)
note: it doesn't overwrite the version in the game folder or disturb any of the files there

2) Removed the glide .dll's from the game folders
(glide3x.dll, glide.dll, glide2x.dll)
note: I did NOT delete but moved them into a separate folder as backup outside the games' folders just in case
note2: latest version of nGlide installs these .dll's to a Windows folder anyways

3) opened latest version of nGlide from Windows start menu, tinkered with settings
I set Video backend to Direct X
Aspect Ratio to: Aspect Correction
3Dfx logo splash screen to: off

left everything else as default

4) Started games from .exe files directly:
Uprising 2 - set to Run as Administrator, loaded runs fine.
Uprising 1 - started from UprisingLauncher.exe , worked fine

IV. Post-Mortem: Why "Potentially" and not "Confirmed" Solved?:
-----------------------------------------------------------------------------------------

Short answer:
Menu screens - they still have the issue for the most part.
All this can change if GoG updates at some point
There could be better, more efficient fixes out there (I'm not an IT guy lol)

Long answer, see below:

Uprising 2 - must run as Adminstrator, otherwise, will result in freezes and problems
Uprising 2 - while the game is loading and even at the menu screens, the cursor can still leave and cross into another monitor, to which clicking anything outside the game monitor will cause the issues to occur.
So don't do that.
Once inside the 3D game itself (like once the map loads and drops you into it), you should be fine.
I've tested it several times without issues.
Just be careful at the menus.

Uprising 1 - I honestly didn't test the Uprising .exe from folder but just the UprisingLauncher.exe (got too tired and wanted to get to some gaming finally!)
I didn't test if the cursor could spill out of the menus like with Uprising 2.
Best to just be cognizant that it could happen. If not at one menu, maybe another. who knows.
But once dropped into the game ready to battle, had no issues.

Final Notes:
If GoG patches the game, its possible all this stuff I just went over could be undone and no longer relevant lol.
I'm not IT/software/technical guy and I don't know if any of this will work for anyone else, it's for informational purposes and I was very frustrated GoG hadn't done anything to fix this, so took the time to try and find a way to make it work...and it seemed to work; and why keep this to myself? I hope this helps others but always be wary, I'm not responsible if you break your stuff, always note your steps and have a backup plan (example: move files rather than delete so you have them to put back in place if moving them didn't work lol).

*As mentioned, it's possible that just moving out those glide dlls is all that needs to be done, aside from launching U2 in Admin mode. Or maybe some other thing can fix this too.

Good luck!
Post edited January 28, 2020 by NerevarineGMSV
dude, installing the latest Nglide made the game A LOT more stable, just install it, setup on Vulcan and voila! it crashes way less now.