It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I'm writing this just in case someone else had the same problem.

In case of the general protection fault crash on startup, it is recommended to exclude Unreal.exe from DEP ( or disable DEP for everything but Windows Services etc, but i tried to avoid this ).

This however did not work for me, even tho i had added Unreal.exe to the exclusions - and reboots did not help either.

After a bit of registry forensics, it turned out that there was actually a typo introduced by Windows itself, in the DEP related registry key for the Unreal.exe

The area where the keys are in the registry :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

If you have added Unreal.exe to the DEP exclusions, you should find the key for it in this list.

The "Data" value of it should say "DisableNXShowUI" for the DEP exclusion to work.

In my case the "Data" value was "HIGHDPIAWAREDisableNXShowUI" - yes that is without a space between the words. This seems to be what caused the problem. Windows for some reason did not put a space between these keys.

I just deleted the HIGHDPIAWARE part of the value and saved, but it should be enough to just put a space manually between HIGHDPIAWARE and DisableNXShowUI, and it should work too.

In any case, this made Unreal finally work for me with the DEP exclusion.

Hope that helps someone, maybe.
avatar
rebb: I'm writing this just in case someone else had the same problem.

In case of the general protection fault crash on startup, it is recommended to exclude Unreal.exe from DEP ( or disable DEP for everything but Windows Services etc, but i tried to avoid this ).

This however did not work for me, even tho i had added Unreal.exe to the exclusions - and reboots did not help either.

After a bit of registry forensics, it turned out that there was actually a typo introduced by Windows itself, in the DEP related registry key for the Unreal.exe

The area where the keys are in the registry :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

If you have added Unreal.exe to the DEP exclusions, you should find the key for it in this list.

The "Data" value of it should say "DisableNXShowUI" for the DEP exclusion to work.

In my case the "Data" value was "HIGHDPIAWAREDisableNXShowUI" - yes that is without a space between the words. This seems to be what caused the problem. Windows for some reason did not put a space between these keys.

I just deleted the HIGHDPIAWARE part of the value and saved, but it should be enough to just put a space manually between HIGHDPIAWARE and DisableNXShowUI, and it should work too.

In any case, this made Unreal finally work for me with the DEP exclusion.

Hope that helps someone, maybe.
To avoid a lot of issues with Unreal, I installed the unofficial Oldunreal's 227 patch.
avatar
hudfreegamer: To avoid a lot of issues with Unreal, I installed the unofficial Oldunreal's 227 patch.
I had the 227i unofficial Patch installed, the same thing happened with it unfortunately.
But yes, very much recommended to use it.
Post edited April 05, 2021 by rebb
avatar
rebb: I'm writing this just in case someone else had the same problem.

In case of the general protection fault crash on startup, it is recommended to exclude Unreal.exe from DEP ( or disable DEP for everything but Windows Services etc, but i tried to avoid this ).

This however did not work for me, even tho i had added Unreal.exe to the exclusions - and reboots did not help either.

After a bit of registry forensics, it turned out that there was actually a typo introduced by Windows itself, in the DEP related registry key for the Unreal.exe

The area where the keys are in the registry :

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

If you have added Unreal.exe to the DEP exclusions, you should find the key for it in this list.

The "Data" value of it should say "DisableNXShowUI" for the DEP exclusion to work.

In my case the "Data" value was "HIGHDPIAWAREDisableNXShowUI" - yes that is without a space between the words. This seems to be what caused the problem. Windows for some reason did not put a space between these keys.

I just deleted the HIGHDPIAWARE part of the value and saved, but it should be enough to just put a space manually between HIGHDPIAWARE and DisableNXShowUI, and it should work too.

In any case, this made Unreal finally work for me with the DEP exclusion.

Hope that helps someone, maybe.
YOU ARE TRULY GOD. THANKS YOU BROOOOOO YOU SAVING MY LIFE