It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Got a new laptop so starting Unepic arrow key was broken on old one so that ended my Unepic playing for a long time.

Anyhow, thought was odd when started my first character, with tutorial, and game asked if I wanted to change from Espanol. Seems English would be default.

So, wanted to start a archer character now...skipped tutorial. Language is Espanol.....I cannot change it, seemingly. I know where to go to change it...Options/Languages.....but I hit Enter, point with mouse....nothing can get rid of Espanol.

No posts in this topic were marked as the solution yet. If you can help, add your reply
Now, even my regular 1st character's hearing Espanol.....loaded my save game just to see, and yep.....tried a 3rd new character, with tutuorial, and didn't get the language option this time....just started up in Espanol.

This is ridiculous. Not going to play like this, so hope figure out how to fix this soon.

Edit: I have looked back 5 pages here and Googled this, but see no similar issues....seems you could at least choose a different language and change it....not working. Not working in game, or at the title screen Options.
Post edited November 06, 2019 by billybgame
Seems I figured this out myself.....under Voices, Espanol was toggled on.....changed that and problem solved. Odd....not sure how that happened.....and why wouldn't Language be where you set this?