It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Klumpen0815: As long as I can't download installers from Steam without any client, there isn't anything DRM free.
Good grief, that's ridiculous (and yes I know exactly what I'm talking about.) Gee, does that mean GOG has DRM because I have to use a browser or Galaxy to download the game? Of course not. How I download it has nothing to do with whether or not I have to "run the client" to play the game--which I just explained to you isn't necessary with all Steam titles. And it's not. I can take those Steam files and move them anywhere and they'll run. I can save them to disk and copy them back later and they will run even if Steam is nowhere installed. I was just educating you a bit about Steam, to clear up some misconceptions you had--not all Steam titles use DRM. (Having to use a Steam client to download a Steam game is no different than using a browser or Galaxy to download a GOG title. It's not DRM.)
For your info: I have a dual-boot setup with a current Linux and my last Windows (XP). Most stuff runs so well and easy on Linux, that the Windows partition is mostly a waste of space and will be drastically reduced soon since I rarely boot it at all. Since I wouldn't go online with any Windows for many reasons, Steam wouldn't be an option anyway and I have no interest in or use for client bound software.
Great--you know what? I asked that question in my original post, so all you had to do was say, "Yea, I dual-boot"--so really, guy, it's more like you trolling me, eh?...;) I mean, I wasn't asking about "most stuff" I was asking specifically about games. Sorry if I stepped on your toes. Guy, I don't care if you run Linux or you don't--that had nothing to do with my question about dual-booting to Windows for playing games. Thanks again for answering...
waltc: I mean, I wasn't asking about "most stuff" I was asking specifically about games.
I actually meant "most games" too.
You have no idea how gaming on Linux developed in the last years, I didn't know about it either before I made the dual-boot setup and thought I's still need Windows for games, in fact one does not.

There's no point in your lenghty posts. You don't like Linux, you don't support or even grasp any of the ideas behind it and have prejudices, we really know that by now. You also like Steam and don't grasp why others avoid it, we know that too. Case closed.
I'll continue supporting native Linux ports and client free shops with my money and you won't stop me.
I'm not interested in Galaxy, Steam, Windows and many other things for reasons you obviously can grasp as little as how easy Linux gaming has become in most cases. Fine, not everybody has to understand everything, it's just an annoyance when they start pestering about things they don't understand. You are free to open up a topic on the general board and discuss this where it belongs, good luck!
Of course you could also search the relevant topics and read what has already been discussed over and over again, but research isn't everyones cup of tea.
Post edited December 27, 2015 by Klumpen0815
I hope this game will be available on Linux soon, then I will be more than happy to buy it, there's no actually any game like this for Linux available right now. Buying this game and using flawed wrappers like wine is really bad, I wish this game been ported to Linux, authors bring this to the penguins please ;-)!
Thanks for the tips others have posted on getting it running; they pointed me in the right direction. I've got it working flawlessly via wine right now, so here ya go, folks:

-Make a new 32 bit wine prefix for Underrail
$ WINEPREFIX=~/.wine_underrail WINEARCH='win32' winecfg

-Now we attack the various problems. To get the game running we need .net and xna - you can try to install via the bundled version, but I generally find going through winetricks to be cleaner and less likely to fail. Install xna40 and dotnet40 via winetricks.

-The audio has problems and will cause a crash on startup (if everything else is running smooth). Others have mentioned xvid/media codecs as the answer, but for me the answer was installing openal32 via wiinecfg (check the error thrown in the console; mine showed a message about openal).

-Once booted, we have the saves issue. The black screens and game hangs are simply caused by the game trying to save. The issue is a lack of bmp drivers for the thumbnail the game is trying to create. Install windowscodecs via winetricks (remember to preface the command with the location of your underrail prefix!) to solve this, and these issues all go away.

-The game also has some odd pathing issues I haven't experienced with others - that is to say, there's something coded funky which causes the game to look for the data folder in the current working directory you launched from. Be sure to have your terminal open to to the location of your underrail install (ie ~/.wine_underrail/drive_c/underrail, or wherever you chose to install) when you launch the game.
$ cd ~/.wine_underrail/drive_c/underrail
$ WINEPREFIX=~/.wine_underrail wine C:/underrail/underrail.exe

-This makes it a bit awkward to create a shortcut for the game. I got around the issue with the following:
$ urxvt -e sh -c 'cd ~/.wine_underrail/drive_c/underrail; WINEPREFIX=~/.wine_underrail wine C:/underrail/underrail.exe'
Which simply opens a terminal, changes to the correct directory and launches the game from there.

Other than that, the only issue I've noticed is some graphical funkiness at certain resolutions - try changing the resolution to match your desktop resolution if you run into issues with some game information being displayed off screen.

I installed corefonts as well (no reason not to, really), but don't know if that was actually necessary - if there's any garbled text you run across during installations, that's usually the key.

I've been playing for several hours with no issues - autosaves working and all.

Concise version:
-new 32 bit wine prefix
-add openal32 in winecfg/Libraries
-install dotnet40, windowscodecs, xna40 via winetricks
-install and play (launch game from the correct directory!)

If anyone feels like spreading this, feel free to cross post on the official forums / steam / wherever. Cheers.
Post edited December 28, 2015 by LucklessCebu

i have Linux Mint 17.3 64 and i run Underrail without any Errors. I am lvl 6 now so i cant say that i can finish the Game without Errors but until now it works very well.

Every thing is working. Making a Char, Sound, Autosave, manual Save and load, walking around, Quests everything you could make with lvl 6.
There are no Graphic glitches or some thing like that.

For me its working to 100%. Thanks to a guy named booman on the playonlinux Forum:

h t t p s : / /

I only changed the Desktop size to 1600x900.

Maybe it helps some one too.
Ah, each time this game is on a sale I get to it and check... and find out it's Windows only. Meh. And then I rediscover for then 10th time it is written in C# + .net and using that XNA stuff (which was abandoned by MS) and each time that doesn't improve things.
Relying on Wine and running things there is a bit like walking on thin ice. Somtimes wine / the program I ran there messed up even at things that I deemed harmless. Programs that wouldn't even use real 3D functions.

It's sad because the game itself looks very nice.