It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So I recently purchased Underrail and the Expedition DLC on GOG and so far have been unable to play the game at all.

The first issue I had was that GOG Galaxy froze on 100% of the download so I never got a Play button. When trying to launch the game from the folder itself I would get the Underrail Loading bar for a brief second and then nothing. Looking online the suggested fixes were to pause the download, close GOG and then reopen it. I tried this twice the second time restarting the entire computer after closing GOG. No dice. Then I tried moving the Underrail file to somewhere else, aborting the download and then moving the file back while GOG was closed.

This seemed to work at first as the client detected the files and I now had the option to Play on the Underrail page. But now all that happens is a black box appears on my screen for about 2 seconds and then closes and then GOG says its syncing saves as if I just quit the game. If I try launching from the game folder directly I get the loading bar again and this time I get the start up menu for about 20 seconds but I cant interact with it in anyway.

I have tried most of the fixes mentioned in forums around the net including:
-Reinstalling Microsoft XNA 4.0
-Adding both GOG and Underrail to my Antivirus exceptions (As well as just turning off Avast completely)
-Running as Administrator and changing Compatibility mode
-Verifying the Game Files

The verify has given me two different results one time downloading around 200MB of something which changed nothing. Every time since then it will simply sit on 'checking files 0.0%' until I abort the process.

From what I've read the installation issues and the black box at launch are issues with GOG while the frozen start up menu is an issue with the game which makes it even harder to tell what the issue is.

I finally chose to reinstall from nothing. Now I can hit play within Galaxy and get the Underrail Loading Bar with no Black Screen but once it gets to the start up menu it freezes and crashes.
Post edited September 12, 2019 by flashkill455