It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I had a really bad experience running the game on a linux laptop with intel graphics.

First I needed to assess the damage. The AGS Options allows us to show FPS (remember this page, we'll get back to it later). I modified the file inside the game folder to add the --fps option to the ags64 (and ags32) executables.

The result was clear, while the interior scenes where an acceptable 30-40 FPS, The exteriors scenes (the intro in particular) to drop as low as 15-20. (rain might be a factor here).

I went in the game options to change and go windowed but the resolution stayed at my desktop resolution (1080p) and didn't change performance at all. I needed to edit the $HOME/.local/share/ags/Unavowed/acsetup.cfg (and intensely use the above AGS Options page) to set it to a double resolution. Performance was still sluggish but more playable (it was great at native resolution 360p but my eyesight is not that great).

All my other graphical tweaks (changing renderer, scaling,...) either did nothing or worsened the problem.

I tried disabling the Gnome composer. I quickly learned it was just not possible, so I tried switching to xfce (and disabling compositing in xfce). Lauching the game showed me an immediate boost in performance. Solid 60FPS (vsync was on) on all interior scenes, exterior ones didn't drop below 40 FPS (even the dreaded intro).

My solution will be to drop Gnome entirely but I'm sharing my full experience for those having the same problem,