It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello everyone.

I am brand new here and I have tried searching for a possible solution to my issue everywhere, including this forum and I have not found anything. So please excuse me if I have missed something out of my ignorance.

I have downloaded Unavowed and absolutely love it. I hate the Mac “Magic Mouse” which is more like a “Crappy Mouse”. So I got a new third party mouse that actually works SUPER WELL. Much better, plug and play. That said, here’s my issue:

I have been able to play the game WITH the Magic Mouse and the third party one I purchased. But recently, I opened the game and it works just fine EXCEPT that the game cursor remains stuck in the upper left corner of the screen, as if the game can not recognize the mouse at all. When I move it beyond the screen, the retail Mac cursor shows up. And if I’m in full screen, if I blindly push the mouse cursor to the very top and click, the drop down shows and the small Mac cursor can move along it to exit full screen or close it, etc.

But anytime I click on the game window or make it full screen, the in-game cursor remains unmovable. This happens with my thirds party mouse, and now even when I tried to change back to the original Mac “Magic mouse”, it too is unresponsive.

Has anyone encountered this before? Are there any people with experience in this who could provide help, guidance, advice or a full on solution?

I would love to not have to give up on this game just because I can get the cursor to move. Thanks so much for any help all of you can provide.