It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello guys,

I would really appreciate any of your help. I bought UU2 on GOG service, so I am using version available on this website. I encountered one large problem during my gameplay, as I reached the world of ice caverns. When I passed the guard of the machinery, solved puzzle with switches and finally reached dam control behind doors - I pulled a chain. But it seems that it didn't do anything, the ice at downstairs areas is still not melted (I checked precisely location of the passage to the city at online maps). So my only way to the Anodunos is blocked, and I cannot continue game.

At the beginning, I thought it may be some kind of intentional stopping progress in game, if one doesn't fill other
important quests. But then I went through all walkthroughs I could find, and they all show everything was done correct till the moment. I found 3 blackrock gems, brought them to Nystul and used them on portal in Britannia, met Altara, talked with everyone in castle and killed the Listener. Also, I tried to load previous states of game and use the chain again, but it still doesn't work. Has anyone ever got the same problem? Is there anything to be done? It looks like some really vicious bug, but still I hope there is a solution for that circumstance. Maybe some file hacking?

Thanks in advance.
Ok guys, I think I have finally found the answer on my own. If you ever get the same problem, here is a solution. After making some experimentations, I noticed that chain in dam controls would work only if player has possessed a jewel dagger from Altara. So, after taking from sorceress a quest of eliminating Guardian's imp, one must first go to the ice world. And only after making the things out there, you ought to kill the Listener later. But also, when I went to icy plains before reaching Kilorn Keep and talking with Altara, the dam mechanism didn't work as earlier. So, if you change this sequence of steps, the chain controlling the dam won't work. It looks like a program is expecting to make a contact with Altara before taking this riddle, and the only indicator of such in code is having the dagger from her. Evidently a bug.
Post edited June 10, 2014 by warlord456
Thanks for posting the answer. Ultima Underworld 2 is an awesome game but unfortunately there are a few known bugs. I haven't heard of this particular one before though.

One more hint - make sure you keep at least one savegame from before you talk to Lord British about the servant strike! There's another well known bug related to this conversation which can prevent it from completing, making the game unwinnable.
Maybe try the levitate or fly spell to reach it?
UndeadHalfOrc: Maybe try the levitate or fly spell to reach it?
Why are you necroing a 5 year old thread where the person already found a way to solve their problem?
Heh, sorry , I just use the search feature to only focus on UU1 or UU2 topics and sometimes forget to check the date of the threads.