It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Just bought the game and launched it in both fullscreen and windowed mode - it seems the framerate is tanking every couple of seconds or so. The mouse jitters as well, mouse selection during character creation and around the starting area is pretty much unplayable.

Anyone have some tips to fix this? Am running on a i5-7600 and on Win10-64bit.
Press CTRL + F12 a few times. It boosts the speed in Dosbox.
Things that may help: turning off mouse acceleration and unplugging any joystick or gamepads.
I found that a high polling rate (1000 Hz) in my mouse settings makes my mouse sluggish and unresponsive while playing the game, especially when making small movements. Reducing the polling rate to 125 Hz has resolved that issue.
Post edited August 02, 2017 by stryx
avatar
runab0ut: Just bought the game and launched it in both fullscreen and windowed mode - it seems the framerate is tanking every couple of seconds or so. The mouse jitters as well, mouse selection during character creation and around the starting area is pretty much unplayable.

Anyone have some tips to fix this? Am running on a i5-7600 and on Win10-64bit.
It's the 'cycles' setting in dosbox that's set to 'auto' by default. cycles=20000 works well.