It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I'm having a specific graphical problem. It involves all of the fire and other similar effects in the game being invisible, although sometimes their lighting effect is still fairly clear to see and the sounds are still there. This is a bit of a game-breaker, since there's a corridor early on in the game's intro-sequences that's full of fire you need to magically extinguish to proceed, but it occurs as early on as the Avatar's house and the park (the Moongate you travel through to get to Britannia is likewise invisible, although walking into the space it takes up still takes you to Britannia).

I'm running this on a Windows 8.1 computer running with an NVIDIA GeForce GT 610 graphics card. I've tried disabling some 3D settings for U9 in the NVIDIA Control Panel, but no dice so far.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Answering this myself, as I found part of the solution in another post about this very problem (Ultima IX Special Effects Not Visible).

That said, I also had to run the game in compatibility mode, as attempting this change without that caused the game to crash upon launching.