It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Ultima 8 is best played with Pentagram, even though its GUI is not that advanced! :)

But please post questions on Pentagram in Exult's own forum at http://exult.sourceforge.net/forum/list.php?f=1 <- our forum is very registration friendly and you will get better answers there than here - Almost all of Pentagram developers are from the Exult development team, so asking questions on Pentagram is encouraged there.
I'm posting this because I noticed several questions on exult and it is easier for me to help on our forum.


@Moderator, could you make this a sticky topic?
avatar
DominusExult: Ultima 8 is best played with Pentagram, even though its GUI is not that advanced! :)

But please post questions on Pentagram in Exult's own forum at http://exult.sourceforge.net/forum/list.php?f=1 <- our forum is very registration friendly and you will get better answers there than here - Almost all of Pentagram developers are from the Exult development team, so asking questions on Pentagram is encouraged there.
I'm posting this because I noticed several questions on exult and it is easier for me to help on our forum.

@Moderator, could you make this a sticky topic?
The official page seems to imply that Pentagram is still really buggy. Is that not up-to-date? Just started playing 8 again and would love to try an improved version.
People tend to love Pentagram more than Dosbox to play Ultima 8, and it seems rather stable. We just have never come around to do a proper GUI and, much worse, a proper release.
The warning is the standard release-less warning...