It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I wanted to post this here in case any unlucky retrospective player finds this bug too, on the chance that they might stumble upon this post and see a possible solution.

I was replaying The Savage Empire, using the GOG copy. I discovered a potentially game-ruining bug. I'm certain that I did not experience it the first time I played, which was many years ago, still using DOSBox, but before GOG existed. I don't know whether this bug is caused by a specific version of Savage Empire, or if it's caused by bad luck. I found a Usenet discussion on the bug from 1997, so it isn't specific to GOG or DOSBox.

What happens is that after I killed Thunderer, the T-Rex that had been terrorizing the Sakkhra, by dropping a boulder on its head, the console said "Gold falls!" and then I noticed that my sixth party member, Aiela, was not in my party any more. I tried talking to her, and she was willing to talk, but refused to rejoin and just said she was already following me. I tried reloading, throwing a grenade to loosen the boulder and then switching to Aiela in solo mode, and then she was "stuck" in solo mode. Trying to go back to party mode produced a message to the effect of "can't exit ship." If I dismissed her before killing Thunderer, then my fifth party member disappeared instead. And if I dismiss everyone, then the Avatar himself disappears from my party, and though I can still control him, the party members refuse to rejoin, saying "not while you're on that raft."

My solution involves hex editing. I meticulously compared save files from before and after killing Thunderer to find this. And there's no guarantee that this will work for you. It worked for me, but I don't know that your save structure will be the same as mine.

First of all, back up your save folder before you do any hex editing. Ideally, make a backup right before you kill the T-Rex. You might as well back up your entire game folder, the whole thing is only a few MB.

After you kill Thunderer, save your game. You don't need to quit. Launch your favorite hex editor (mine is HxD for Windows), navigate to your game folder, open the SAVEGAME folder inside, and edit the file OBJLIST.

In this file, go to the address 0x00000FF0. I believe this represents the number of people in your party. For me, the current value is 05, and the value of the same file in the backed up folder is 06. This makes sense, as I had six party members before killing Thunderer, and only five after. If you had fewer than six party members, then I expect your values would be different accordingly. I changed the value to 06, saved, and then switched back to the game. Aiela was back! Everything else seemed fine. Thunderer was dead, the Sakkhra chief acknowledged it, and I kept playing, and eventually beat the game without further trouble.
Post edited October 22, 2019 by ikantspelwurdz
Thank you so much for the work you put into finding and describing this fix!
I've been playing The Savage Empire for the first time just now and read about this problem before. And indeed I ran into the problem, so I guess it happens a 100% of the time.
Your fix works just as described, well done!