It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
The Savage Empire version currently on GOG is 1.6, as you can see when you go to "About The Savage Empire" in the main menu. However, other copies available elsewhere are version 2.1.

Version 2.1 no doubt contains plenty of fixes, as quite a few of the files have different checksums, but the most significant fix is to Tristia's dialogue that stops it from erroneously looping. This means in version 2.1 you can reach the alternate game ending, which just isn't possible in 1.6 due to this bug.

In fact, this bug also means that if you have Aiela in your party and talk to Tristia, you cannot even exit the conversation, forcing you to quit and relaunch the game.

Can GOG update their Savage Empire version to 2.1, or ask EA to provide it?

For those wanting to update to 2.1, just find a copy and drop all the files (minus the SAVEGAME folder) into the SAVAGE directory of GOG's Savage Empire install directory.
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
DeathStrike: The Savage Empire version currently on GOG is 1.6, as you can see when you go to "About The Savage Empire" in the main menu. However, other copies available elsewhere are version 2.1.

For those wanting to update to 2.1, just find a copy and drop all the files (minus the SAVEGAME folder) into the SAVAGE directory of GOG's Savage Empire install directory.
Do you know where it can be found? I have been looking for version 2.1 but no luck yet....The Tristia bug with the 1.6 version has me annoyed enough that I won't play it until its updated.
avatar
DeathStrike: The Savage Empire version currently on GOG is 1.6, as you can see when you go to "About The Savage Empire" in the main menu. However, other copies available elsewhere are version 2.1.

For those wanting to update to 2.1, just find a copy and drop all the files (minus the SAVEGAME folder) into the SAVAGE directory of GOG's Savage Empire install directory.
avatar
Benami7777: Do you know where it can be found? I have been looking for version 2.1 but no luck yet....The Tristia bug with the 1.6 version has me annoyed enough that I won't play it until its updated.
It should be easy to find online. Just Google for savage empire download. You might have to try a few places until you find version 2.1, but it may just be the first result!

Obviously GOG is the "official" version, and I've done my bit by bringing this thread to their attention through a support email. Hopefully they update their version soon so there won't be a need to look elsewhere!
Post edited May 03, 2017 by DeathStrike