It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

It just crashes immediately as i start it, even when trying run with Administrative priviliges, or in compatibility mode, with XP sp 2 and 3. Far as i can remember however, there may be in issue with specific processors running in 64 bit, so i was wondering if anyone could remember the command to start an application in 32bit mode?
It may well be something else that's wrong, so if you have any other suggestions, those would be welcome.
Edit: The reson i remember something about the processor is I own the series on disc, but the Starforce protection on AS makes it unplayable, as the installer will run at startup, only to reboot, and then the system fixes all the cr*p that Starforce pushed into tmy system, prompting the installer for Starforce to run again >_<
Post edited January 05, 2010 by Silvermane
No posts in this topic were marked as the solution yet. If you can help, add your reply
Ok, start off with listing your OS and PC specs. A 64-bit cpu with 64-bit OS works fine with Aftershock for me, nothing needed to be done it just ran without compatibility mode. So it isn't the CPU or OS. Do you have your older disc version installed still? Also did you try uninstalling Starforce, it may be detecting the game running again.
Here is the link to the Starforce removal tool:
Post edited January 05, 2010 by tb87670
Right, tried to install the game, it installed Starforce, i choose not to reboot, and then used the removal tool. It then asked to install starforce again, at which point i accepted the reboot, which lead to complete and utter system failure. Had to do a complete system reinstall. Maybe the GoG file works now if i redownload. Gonna try and see what happens.
Specs are:
OS: 64-bit - Windows 7 Ultimate
CPU: E8500 Intel, Dual core
The rest should be more or less irrelevant.
Update: Nope, problem persists. Memory might be faulty, so it could be because i need to run single core.
Update: Definately something different if i run it on a specific core. ([url=More]http://www.howtogeek.com/howto/windows-vista/start-an-application-assigned-to-a-specific-cpu-in-windows-vista/[/url])
Getting a assert_fatal error:
ver: UFO: Aftershock 1.2
file:c:\workdir\src\libglview\include\../core/mdsstream.h line:32 CMDSStream
error: Can't open "share/configs/option.txt"
Post edited January 07, 2010 by Silvermane
Silvermane: Right, tried to install the game, it installed Starforce, i choose not to reboot, and then used the removal tool. It then asked to install starforce again, at which point i accepted the reboot, which lead to complete and utter system failure. Had to do a complete system reinstall.

It installed Starforce? But GOG's downloads are DRM free, so you shouldn't have Starforce with it. Have you ever installed previous versions of it that did contain Starforce DRM? In any case, you say you ended up having to do a full system re-install (I'm assuming hard drive format and re-install of Windows and drivers from scratch). When you then tried installing from the GOG download, did it mention Starforce again or not?
Silvermane: <snip>

Start by making sure all traces of previous installations of the game are gone and also make sure all traces of starforce have been removed from your system.
From there, install gog's version. Then go to the shortcut gog's installer places on your desktop and under properties > compatibility, tick the run as admin box, and try to run the game then.
Post edited January 07, 2010 by Namur
I've already tried to do it admin style. As for starforce, that's what's on the disc version. As it says in the original post, starforce is more or less the reason i've bought it here through GoG, so i don't have to contend with Starforce. The problem is it just crashes (the GoG one). I think it has something to do with my cpu being multi core, but can't confirm it. Any help with that?
As for removing all traces, because of a starfoce, i had to do a clean os install, so it's as clean as it can be, as i've also already posted
Post edited January 08, 2010 by Silvermane
Started the game, wanted to try again, worked this time, no problems. Dunno if i forgot to update something or whatnot, but it works now. Just shows the importance of remembering that step >_<
I don't know if this patch helps, but here it is
UFO: Aftershock Patch 1.2.1
Download: www.patches-scrolls.de/ufo_aftershock.php
This patch allows you to play the game in Windows 7. Make sure you have updated your game to version 1.2 before applying this patch.
With ATI Catalyst 10.2, AS no longer work...
See on ALTAR forum for a solution I gave.
EDIT: 10.3 works good!, but there are still some rare freezes from the 10.2
Post edited April 26, 2010 by ERISS
bought this game but i dont seem to be able to get this game working, no matter what i try, reinstalled everything but all in vain, i get same stupid error regardless what patch i use, i run under 64 bit windows 7 system... none of the compability modes seem to do anything for the game, of course i run it as administrator, if anyone got some solution please so share :)
This is how I got it working in Windows 7:

1. Install Ufo: Aftershock. DO NOT REBOOT! Otherwise you can't anymore boot to Windows without doing system restore, or clean install in the worst case.

2. Install Patch 1.2. and then 1.2.1. Again, do not reboot.

3. Remove starforce:

Remove these files:

Remove these registry keys:

4. Play! Rebooting is should be safe again.