It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Purchased UFO Aftermath a few days ago and I've got a rather annoying bug with the game.

I can do the Tutorial mission with the first two characters, no problem what so ever.

However, on returning to the Geoscape (the thing where you access R&D, the Squad Loadout, base management etc) the game is constantly paused, and I am not able to continue at all.

I know the keys to pause, resume, increase and decrease game speed (Spacebar and the Numpad Plus and Minus keys), but the game quite literally refuses to unpause itself.

The game hasn't crashed, as I can still rotate the globe, and view base information, access the R&D screens etc, also clicking the increase / decrease game speed icons in the top right corner still produces the "tick tick tick" noises.

Also as a minor concern, the starting movies do not play, they start up then freeze, however I can still use escape to bypass them into the main menu. Again a minor concern.

So at present, all I can do is play the Tutorial mission, and that's it.

Anyone got any ideas?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Maybe you don't have a supported graphic card.
Ok, so how do I find out if I have an unsupported GFX card? Is there a list of UFO: Aftermath known issues stating the known incompatible GFX cards?

GFX card in question is a ATI Radeon HD 5700 Series.

Just for clarification though - the actual tactical game (ordering Soldiers around, shooting enemies and picking up stuff etc) works flawlessly - the only issue I've got is that the Geoscape cannot be unpaused.

There seems to be no graphical errors in the tactical game either.

As I said, the game hasn't crashed, I can use all the user interface options to view R&D screens, rotate the globe, zoom in, zoom out.

I can access the main menu, save any game progress, view the game credits. The music continues to play.
Maybe you have a DirectX 9 problem.
Ok, tried re-installing UFO Aftermath, again to no avail. However, through some kind of fluke effort, I have managed to get time to progress. Time does indeed progress VERY slowly, even with the speed setting to the very fastest. It's hard to describe how it progresses, so bear with me:

Perhaps it could be graphical, as the Geoscape seems to run at a very low FPS time wise - it's not noticeable when spinning the globe using the UI and the shortcut keys - the rotation of Earth in the simulation is smooth and seamless. BUT the actually passage of time again runs at a slow FPS type thing - it'll be on for example 16:30pm for about 30 seconds, maybe more, then the simulation will update and it's maybe 16:50pm and again time will not progress.

Music continues to play on as normal, and all UI functions, such as accessing the R&D screens, managing my Squad, are all immediately loaded upon clicking on the relevant buttons.

All Geoscape actions seem to progress as normal in between each of the time skips. I have since managed to do a second mission, but only through sheer persistence and a lot of waiting around. As before, there are no issues in the Tactical side of the simulation (i.e. the bit where you order Soldiers around). FPS is very smooth there.

Just to clarify though, my computer itself is not old, it's just the Graphics Card. Had a Core i5 3570K 3.4GHZ Quad Core Processor, 16GB of Corsair 1600MHZ DDR3 Memory, and an Asus P8Z77-V LX Motherboard installed just before Chrismas last year, which has worked well in every other game thus far.

Now if it is a Graphics issue, I need some detail information on how I can diagnose this, because frankly I do not know how to proceed.

Just thought of something - is there a way to display FPS ingame, preferably in both the Tactical and Geoscape portions of the game? Would help with diagnosis.
Post edited October 24, 2013 by Nebhead
Ok, have finally managed to solve the issue:

As detailed below by user SkyLord972 in the thread "Aftermath runs choppy", I have been able to continue the game normally in the Geoscape by doing the following:

-------------------------------------------------------------------------------------------------------------- ---------------

Originally posted by SkyLord972:

For ATI Cards, the problem lies on the Catalyst Drivers. Fortunately, the solution is also by tweaking Catalyst.

For Win7 (32bit & 64bit) Change your Catalyst -> 3D -> AA (Anti Aliasing). unchecked the "Use application settings". set the level to 4x and Select the filter : Wide-tent.

For WinXP on Catalyst -> 3D -> AA. unchecked the "Use application settings". And select the filter to Wide-tent.

Checked back the checkbox if you want to play newer games... :)

-------------------------------------------------------------------------------------------------------------- ---------------

Am now able to play the game normally, didn't find the thread originally as I was not sure of the search terms for my problem, went with "Constantly Paused Geoscape" as that is what it seemed to be at the time.

Many thanks SkyLord!