It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi, I have two characters in UFO AS who are supposed to dual wield (a ranger and a cyborg with the chipset) but they don't. Is there a button to press to achieve that or something?, do you have to use unmod weapons? That really bothers me. To explain, the character holds the two weapons but doesn't shoot them together, he justs shoots one while holding the other down like any other character with two guns in his hands.

Edit: Update: So my Ranger does dual wield, but he didn't before, just when he got ranger second level I had tried to and it didn't work so I had him man the shotgun since then, I had not tried with him since because he rocked the shotgun pretty well. The ambi arm not working with the cyborg I tried again with the ranger and miracle, it worked. But it still doesn't work with the cyborg. There is other problems with the cyborg: his speed is listed as super heroic but he is way slower than another character with superheroic speed. And in game when right clicking on his portrait, his speed alternatively show heroic or super heroic. It's really weird.
Post edited October 04, 2013 by Seanny_Crow
Cyborg dualwield chipset does not work, it is useless, it is a remaining bug of Aftershock.

IIRC, dualwield capacity works if you have same firing weapons and their tools (you can have different ammo).
Its graphic animation is not shown, but the damages are added.
Post edited October 05, 2013 by ERISS