It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

mutishev: I will, but first I have to find it ;)
obi4ammama: Ok, i think i have a solution to this problem. When you are on the settings menu, under the resolutions drop down menu on the left side, there is a direct draw option. Just opt out (untick) it and the game should be starting normally. Hope that helps :)
Thanks for the advice!
I have installed the GoG english version
Hey guys, I already bought the GoG version, but wouldn't mind if the admins contact you for the BG one too :)
Post edited April 02, 2018 by lokalizatora