It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm constantly experiencing issues with the game, and I suspect it's DOSBox. The game runs fine for the most part, but every couple of seconds (from 5 to 10), the game goes into a hiccup and lags heavily for a second or so, and severely impacts the gameplay. I've tried everything, raising the memsize value in the settings, trying with every graphic setup possible, and restarting my SO without anything running in the background.

And before anyone says anything, it's not a problem with my RAM or unnecessary processes running in the background. I have 32GB of RAM, and as I've said, I've tried with absolutely the minimum required processes, but the game still has these hiccups.

Does anyone have the same issue and has found a solution?
No posts in this topic were marked as the solution yet. If you can help, add your reply
I can't play it either. The lag is just terrible
Go to the Graphics Setup shortcut and try another renderer. Chances are, Windows 10 screwed up yet another ancient API.
Which version of windows 10 ? (As Darvond wrote, maybe one of the newer ones changed something).
You should try with OpenTyrian (Source port)

Dowload here:
It doesn't matter how much ram you have if dosbox isn't set up to use it. =D

Find the dosbox config in the game folder and make sure the values are as below:

fullresolution=#x# (set your resolution; ex 1280x720)



Post edited March 16, 2020 by planewalker_dk