It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

NightOnEarth: Hello,

i installed Tyranny without any problems yet after launching it i get the following error :

Failed to initialize player

Failed to initialize Direct3D.
Make sure you have at least DirectX 9.0c installed, have drivers for your
graphics card and have not disabled 3D acceleration
in display settings.
InitializeEngineGraphics failed

I do have the most recent DirectX version, also i reinstalled it just to make sure
I have the most recent graphics drivers, reinstalled them just to make sure
I double checked if hardware acceleration ids enabled, and it is

Yet i cannot launch Tyranny, any ideas?
Please reinstall Microsoft Visual C++ 2012 Redistributable, it should help with the problem.
NightOnEarth: Hey Razikale,

thanks a bunch, first i installed the Visual C++ 2012 Redistributable for x64 systems and got the same error again ( though i run a 64bit win7), then i installed the version for x86 systems and it worked !

you made my day !
Sorry, should have specified it is always good to reinstall/install both version of the redist (32 and 64bit) just in case. Glad the game is working for you :).