It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
high rated
In June last year, the devs on Steam said they released a small fix to allow UI scaling on the Steam version ( http://steamcommunity.com/app/1930/discussions/0/357287304415595014/?ctp=2#c350533172703555738 ), and it was great. But my GOG version still had the small (on 1080/1440p) UI. As with both versions installed, GOG's also had scaling, there was probably a shared file/entry somewhere.

Apparently GOG's version is patched too, it's just that the values for the fix may still be vanilla. So, to make the UI bigger on GOG's, open the registry (Win+R and type 'regedit'), and search for this (the game needs to be launched at least once) :

[HKEY_CURRENT_USER\SOFTWARE\Reality Pump\TwoWorlds\Interface] , you should see 'MaxInterfaceWidth' .

Make a backup of your registry before changing the value if you're unsure of what you're doing (select Comptuer at the top of the list, then File=>Export for a full backup, or simply right-click on 'Interface' for example and Export for a game entries backup. You can even add these entries as Bookmarks!).

Double-click on MaxInterfaceWidth, you can enter a new value (in hexadecimal). Vanilla is 400 (1024), Steam's is 1000 (4096). Then just click OK - you can still check the changes in-game without closing the registry.
I assume you can set it to whatever you want (even smaller than 400), at some point though it just won't make a difference on something smaller than a 4K monitor. I'm using 600 (1536), it doesn't take all the height on my 1440p monitor, and is still very comfortable.
Post edited June 05, 2017 by Darucas
avatar
Darucas: In June last year, the devs on Steam said they released a small fix to allow UI scaling on the Steam version ( http://steamcommunity.com/app/1930/discussions/0/357287304415595014/?ctp=2#c350533172703555738 ), and it was great. But my GOG version still had the small (on 1080/1440p) UI. As with both versions installed, GOG's also had scaling, there was probably a shared file/entry somewhere.

Apparently GOG's version is patched too, it's just that the values for the fix may still be vanilla. So, to make the UI bigger on GOG's, open the registry (Win+R and type 'regedit'), and search for this (the game needs to be launched at least once) :

[HKEY_CURRENT_USER\SOFTWARE\Reality Pump\TwoWorlds\Interface] , you should see 'MaxInterfaceWidth' .

Make a backup of your registry before changing the value if you're unsure of what you're doing (select Comptuer at the top of the list, then File=>Export for a full backup, or simply right-click on 'Interface' for example and Export for a game entries backup. You can even add these entries as Bookmarks!).

Double-click on MaxInterfaceWidth, you can enter a new value (in hexadecimal). Vanilla is 400 (1024), Steam's is 1000 (4096). Then just click OK - you can still check the changes in-game without closing the registry.
I assume you can set it to whatever you want (even smaller than 400), at some point though it just won't make a difference on something smaller than a 4K monitor. I'm using 600 (1536), it doesn't take all the height on my 1440p monitor, and is still very comfortable.
Thank you for this!!!! I can finally play in 4k - was playing at lower resolution just so the UI wouldn't be so small.
There's no such value in regedit, tried to add it manually but it doesn't help with scaling at all.

Any way to increase the UI at resolution 1920x1200 nowadays?
avatar
Lord Bafford: There's no such value in regedit, tried to add it manually but it doesn't help with scaling at all.

Any way to increase the UI at resolution 1920x1200 nowadays?
Had to change to windowed mode (then increase resolution) and then switch back, to up the display resolution. Worked for me.
avatar
Lord Bafford: There's no such value in regedit, tried to add it manually but it doesn't help with scaling at all.

Any way to increase the UI at resolution 1920x1200 nowadays?
avatar
Rick_Aka: Had to change to windowed mode (then increase resolution) and then switch back, to up the display resolution. Worked for me.
I tried to help a friend creating MaxInterfaceWidth entry on registry in DWORD 32 bits with a value of 1000 on hexadecimal and never worked.

Even for 1920x1080 UI looks small. Playing on 1600x900 looks bigger but you lose sharpness... and going lower is even worse.