It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi guys,

Until Nightdive establishes a presence here I am going to start a bugs and issues thread.

Note: I am not a night dive employee, I do not work for them I am only doing this a service.
If you use steam or want to have a look there is the official bugs thread on steam:

Issues I have encountered:
low framerate around 20 to 30
the flashlight not illuminating the area bug
options menu states 0mb of 0mb (same bug as several others)
the texture issue as shown here from user Dominic: [Workaround: set r_gl_useUniformBuffers to 0 via console or by finding the value in kexengine.cfg in the install directory. ]
The game seems to have issues with ATI/AMD cards and a contact tells me they had no AMD users for testing.
Post edited March 17, 2017 by Lord_Kane
Lord_Kane: The game seems to have issues with ATI/AMD cards and a contact tells me they had no AMD users for testing.
So far I've only tried the game under Linux(Manjaro 64bit, KDE kernel 4.9) via wine, and seems to run fine (AMD GPU R9 390X)

Need to play more and also try on windows.
So far the shotgun aim seems to be off to the topright.

And the game is locked at 60fps (62 ingame fps counter). Changing seta cl_maxfps doesn't work.
okay there is a quick workaround for this texture issue now :)

Open the console (~, next to the 1), set r_gl_useUniformBuffers to 0 and restart the game.

If for some reason you can't operate the console, look for the value in your kexengine.cfg in your Turok2 folder, and change the value there.

this fixed the problem for me :)

does anybody have the R6025 Bug on Startup?

"Microsoft Visual C++ Runtime Libary

Runtime Error

Program: C:\GAMES\Turok 2\horus_x64.exe

- pure virtual function call"

Any ideas?


I solved the problem... -.-

At first i try to install and update all Microsoft Visual C++ Runtimes from that page

But that does not have any effect.

So I try a random shot and update my AMD GPU drivers and it works. In the "detail list" of the extraction appears some vcr.exe files and i think they solve the problem.

Maybe anyone at the internet had the same or similar problem and need this hint "think simple" too :D
Post edited March 18, 2017 by GeraltVonHessen
I'm firing blanks with normal arrows using the Tek bow in scope mode. Anyone else having this issue?