It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

My gamepad controller from Gembird doesn't work. I tried x360ce emulator and it didn't helped.. Any suggestions?
Post edited October 08, 2019 by Matys92_PL
Matys92_PL: My gamepad controller from Gembird doesn't work. I tried x360ce emulator and it didn't helped.. Any suggestions?
I'm sorry to hear the game is not working with your controller. Unfortunately Trine 4 only has native support for X-input controllers (basically Xbox 360, Xbox One and compatible controllers). You can try to set-up other controllers with emulators but unfortunately if that doesn't work your only option might be to play with a keyboard and a mouse. Sorry for the inconvenience.

- Linda / Frozenbyte Support
Thanks to GOG support I've got the soluiton!

1) Download this emulator
2) Put the downloaded program into the game's installation folder (If you installed the game from Galaxy, select it in Galaxy and press More -> Installation Management -> Show Folder)
3) Then run the program inside the game installation folder. You will be asked to download Xinput libraries. Allow it. Then it will ask you to download the default controller settings and select the Internet auto search option.
4) Go to the Game Settings tab. Add Trine 4.exe here by pressing the Add button (you will have to indicate where Trine4.exe is located). When it is added, select all 64-bit options from the Xinput files group. Then press Apply / Synchronize Settings. Start the game.
It works perfect for my Gembird controller ;)

PS: In Game Settings I already had Trine4.exe but in differrent folder don't know why..
I am trying to play Trine 4 with two DualShock 4 and one DualShock 2 controller (using USB adapter). The DS2 is recognized as a USB controller by the OS while the others are set up using the DS4Windows tool.

By default, Trine 4 recognizes only two DS4 controllers while the USB one is not working. If I use the x360ce tool, then all DS4 controllers stop working in-game while the USB one starts functioning. The strange thing is that DS4s are still functional in OS with x360ce showing input keys being pressed. I've tried enabling PassThrough for DS4 controllers in x360ce but still no luck. Am I doing anything wrong here? Any suggestions?