It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello, I can't download the game "Tower of Time". Everytime I click on "get free", I get redirected to the main page of
No posts in this topic were marked as the solution yet. If you can help, add your reply
Same here. Even more bizarrely, people on Twitter who were apparently having this problem claimed that the solution was to scroll down on the homepage and click on the banner between "Play before the year ends" and "Recommended for you." But that just takes me to the game's page, which contains a link back to the homepage!
Same here, been trying since day one when it was supposedly free. It keeps redirecting me to buy the entire the witcher 3 collection. Same with the link which goes to " "

The banner method mentioned re-directs to the tower of time all over again, creating a infinite loop. Tried on multiple browsers, multiple different operating systems (windows 10, windows 7, kubuntu, ubuntu, tigeros, android 9.0, tinzin 1.3) Attached is the screenshot of what the banner is that folks mention works, but in my case and a variety of tests, does not work.

okay.. every format of image I try to upload is wrong. But I got it to work at the time of this posting. Weird, worked on the Samsung s9+ dex mode chrome web browser, didn't work on it in its non dex mode variant. Just some information for those who struggling to get it. I just got it using s9+ Dex mode
Continue scrolling down the store's main page to see the "get a FREE" button on the tower of time.
Oh FFS. You can't just click anywhere on the banner (the lower one on the homepage, below "Play before the year ends"); you have to specifically click on the part of the banner that is a button saying "Get it FREE".
I clicked on 'get it free' in Firefox and it just took me into the same loop as everyone else. I then clicked on a random part of the banner in Chromium and it worked.

I honestly don't understand why GOG have to make this so complex that it breaks on many people's browsers.
You had to click on the giveaway on the main page. Real complex stuff.