It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm having a problem where character required complete steps in main quest won't Talk to the Last Castoff.

I just fixed the clock in Circus Minor and was told to seek out Matkina in the Underbelly (Cold Calculating Jack main quest started). I talked to Manth Pa, and he directs me to Mapper. When I go to Mapper and click on him to Talk nothing happens. So I tried talking to everyone I can find. But nothing seems to move the CCJ quest forward.

Also coincidentally previously I was able to Talk with Ch'kekt, and now he won't talk either. I've went back to multiple older saved games that were well before the CCJ quest started, and none of them allow me to talk to either Mapper or Ch'kekt. I've also rebooted and retried several older saves.

Although I truly love playing Tides, I really don't relish having to replay almost 20 hours from scratch...

Other than restarting my game from the beginning are there any other options to fix this problem?

** UPDATE **

I ran Verify in GOG Galaxy, and that fixed the problem. I guess some other application installed after Tides changed file(s) that Tides needs.
Post edited January 03, 2019 by craig_s_russell
No posts in this topic were marked as the solution yet. If you can help, add your reply