It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've got about 60 hours in Torchlight and have enjoyed it immensely even though the main quest was sorta short in that I finished it at roughly the ten hour mark still I have found things to do mainly in the vault that keeps my interest.

After 60 hours as you can imagine I am very attached to my character. Torchlight has been so stable for me only crashing three or four times in all of my play, and each of those other crashes requiring nothing more than merely restarting the game and all was well I was a little shocked to find the latest crash has seemingly corrupted my save games file.

When I try to load Torchlight now I get to the splash screen and find a cursor filled with sand that never goes anywhere. Out of curiosity I uninstalled and reinstalled the game and everything works fine, but when I copy over my old saves directory the same thing happens the program gets stuck at the splash screen and never goes any further.

If I delete the 0.SVT file the game loads fine but without my character, the only mods I loaded where the Total Respec mod but I haven't used any of the potions except one single time and that was maybe at the 15 hour mark. At this point I am wondering if there is any way to fix my seemingly corrupted save games?

I also tried renaming my backup.temp file to 0.SVT and still the same thing happen, one other thing I found odd here was the two files are NOT the same size, they are close but not the same I don't know if that is significant or not. I also don't understand how both the main save and the backup save could become corrupted at the exact same time?

All my other games and apps are still running normally and I even checked my SSD using the Intel SSD Toolbox to see if something was wrong with my SSD but all seems fine as mirrors my own experience using the PC.

I am not interested at this point at just starting again from scratch so if I can't get this fixed as much as I have enjoyed this game I think it will be time to move on to the next one. Any help here would be appreciated.
If anyone else is having this problem, I got this response over at the RunicGames forums, so far it seems to be working. Fingers crossed.
What was the response?