It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
For those folks running on Linux, I ran into the following issue when running Toonstruck:

scummvm_x86_64: error while loading shared libraries: libjpeg.so.8: cannot open shared object file: No such file or directory.

It would seem that GOG did not package libjpeg8 with the installer and I needed to build and link this library to get Toonstruck working for me (I'm running Fedora BTW).

Hopefully the following should help:

### Step One ###
# Ensure you have build-essential or your distro's equivalent installed.
# For Ubuntu based distros
$ sudo apt-get update && sudo apt-get install build-essential

# Or in my case Fedora
$ sudo dnf install @development-tools

### Step Two ###
# Download the necessary version of libjpeg source code and extract
$ wget http://www.ijg.org/files/jpegsrc.v8d.tar.gz
$ tar zxvf jpegsrc.v8d.tar.gz
$ cd jpeg-8d

### Step Three ###
# Build the library
$ ./configure
$ make
$ sudo make install

### Step Four ###
# Create a symbolic link so the game can find the missing library
$ sudo ln -s /usr/local/lib/libjpeg.so.8 /usr/lib64/libjpeg.so.8

You should now be able to run the game!
avatar
whkr1: For those folks running on Linux, I ran into the following issue when running Toonstruck:
Or, you could just use your distro's scummvm. I'm sure Ubuntu/Debian has a recent enough version. I never use gog's scummvm, dosbox, or ags, even if they're Linux native.
avatar
whkr1: For those folks running on Linux, I ran into the following issue when running Toonstruck:
avatar
darktjm: Or, you could just use your distro's scummvm. I'm sure Ubuntu/Debian has a recent enough version. I never use gog's scummvm, dosbox, or ags, even if they're Linux native.
Or they could fix the packaging. It is kind of annoying to have anything to do in this regard.
avatar
pllx: Or they could fix the packaging. It is kind of annoying to have anything to do in this regard.
Have you looked at the system requirements? A few Ubuntu LTS releases only (16.04 and 18.04, although the minimum requirements also list 14.04 and Mint 17). If it works there, there is no need for them to fix it, because they never claimed it would work anywhere else. I don't meet the system requirements for *any* game here on gog, because I don't use Ubuntu and I don't use Windows (or MacOS, for that matter). Yet, you don't hear me complaining (at least not about this). I never even tried the bundled scummvm, as I run all my scummvm-capable games using my system scummvm and my own wrapper scripts. Deleting the supplied scummvm saves space as well. What do you do when gog only packages it with the WIndows version of scummvm (e.g. King's Quest series, Space QUest series, Quest for Glory series, Zork grpahic adventures)? Or only the Windows version of DOSBox? It's not like you have to put a lot of work into it, or even do it more than once. A few minutes and you're up and running, no problems.
avatar
whkr1: For those folks running on Linux, I ran into the following issue when running Toonstruck:

scummvm_x86_64: error while loading shared libraries: libjpeg.so.8: cannot open shared object file: No such file or directory.

It would seem that GOG did not package libjpeg8 with the installer and I needed to build and link this library to get Toonstruck working for me (I'm running Fedora BTW).

Hopefully the following should help:

### Step One ###
# Ensure you have build-essential or your distro's equivalent installed.
# For Ubuntu based distros
$ sudo apt-get update && sudo apt-get install build-essential

# Or in my case Fedora
$ sudo dnf install @development-tools

### Step Two ###
# Download the necessary version of libjpeg source code and extract
$ wget http://www.ijg.org/files/jpegsrc.v8d.tar.gz
$ tar zxvf jpegsrc.v8d.tar.gz
$ cd jpeg-8d

### Step Three ###
# Build the library
$ ./configure
$ make
$ sudo make install

### Step Four ###
# Create a symbolic link so the game can find the missing library
$ sudo ln -s /usr/local/lib/libjpeg.so.8 /usr/lib64/libjpeg.so.8

You should now be able to run the game!
Just to mention the following option to get it to run:

Had the exact same problem with 'Indiana Jones and the fate of Atlantis' on Fedora 30 but instead of installing the missing library I did the following:

#### Step One: Install Fedora Scummvm package
$ sudo dnf install scummvm

#### Step Two: Start scummvm and add the downloaded game from GOG
$ scummvm

Click 'Add Game'
Choose the 'data' folder within the downloaded GOG folder
Run the game

At least worked for me
Just for the sake of it, an alternative way to fix the game on Debian:

Install the debian version of scummvm:
$ sudo apt-get install scummvm

Now modify the following script (i'm using the default installation folder). You can use any text editor you want, i use leafpad, if you dont't have it installed, do "sudo apt-get install leafpad"
$ sudo leafpad /home/yourusername/GOG Games/Toonstruck/support/gog_com.shlib

Now search towards the end of file, where it says "run_scummvm()", you should find the following function:

run_scummvm() {
local conf="${1}"
./scummvm/scummvm -c "${conf}" --themepath=scummvm
}

Simply change the scummvm location to the debian version you installed in the first step, as follows:

run_scummvm() {
local conf="${1}"
/usr/games/scummvm -c "${conf}" --themepath=scummvm
}

Now you should be able to run the game normally, both from command line and from the GOG desktop icon
Just an alternative idea ;-)
Post edited January 07, 2020 by rekotc
avatar
rekotc: Just for the sake of it, an alternative way to fix the game on Debian:

Install the debian version of scummvm:
$ sudo apt-get install scummvm

Now modify the following script (i'm using the default installation folder). You can use any text editor you want, i use leafpad, if you dont't have it installed, do "sudo apt-get install leafpad"
$ sudo leafpad /home/yourusername/GOG Games/Toonstruck/support/gog_com.shlib

Now search towards the end of file, where it says "run_scummvm()", you should find the following function:

run_scummvm() {
local conf="${1}"
./scummvm/scummvm -c "${conf}" --themepath=scummvm
}

Simply change the scummvm location to the debian version you installed in the first step, as follows:

run_scummvm() {
local conf="${1}"
/usr/games/scummvm -c "${conf}" --themepath=scummvm
}

Now you should be able to run the game normally, both from command line and from the GOG desktop icon
Just an alternative idea ;-)
I

I tried this and it looked promising, but it didn't work for me. I am triyng to run Blade Runner. When I follow your instructions and run Blade Runner with the desktop icon, I get the Scummvm window and select Blad Runner, but when I try to run it it tells me it could not find an engine capable of running it.

When I try running the game with start.sh from the command line, I also get the same scummvm messge, but when I quit I get some command line error messages:
unning Blade Runner
Using configuration file: project_nov.ini
WARNING: SDL mixer output buffer size: 2048 differs from desired: 4096!
User picked target 'project-nov' (gameid 'bladerunner')...
Looking for a plugin supporting this gameid... failed
WARNING: bladerunner is an invalid gameid. Use the --list-games option to list supported gameid!

I am trying to run this from a Chromebook, so I am certain this is complicating things a bit, but I was hoping I would be able to find a way.