It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
To run GOG Tomb Raider 1 on Linux, you have to use a modified version of dosbox wich support 3DFX games.

1) install openglide library:

open a terminal and launch this commands:
$ cvs -dserver:anonymous@openglide.cvs.sourceforge.net:/cvsroot/openglide login # push "enter" for password
$ cvs -z3 -dserver:anonymous@openglide.cvs.sourceforge.net:/cvsroot/openglide co -P openglide
cd openglide
./bootstrap
./configure --prefix=/usr
make
sudo make install

2) make a 3dfx dosbox version

Default dosbox does not support 3dfx game by default, you have to patch the sources and compile your special version:

svn co https://dosbox.svn.sourceforge.net/svnroot/dosbox/dosbox/trunk dosbox

then download dosbox glide patch on this forum:
http://vogons.zetafleet.com/viewtopic.php?t=16462&start=0&postdays=0&postorder=asc&highlight=

extract the patch from dosbox_glide.zip file.

Apply the patch:
cat dosbox_glide.diff | patch -p0

It's important the dosbox source folder name have to be "dosbox" or the patch will not find the sources.
Don't worry about patch reject, I had 4 rejects on my install and it's only because the dosbox svn source has yet integrated code from the glide patch.

You can now compile your dosbox glide version:
cd dosbox
chmod +x autogen.sh
./autogen.sh
./configure CPPFLAGS="-I /usr/include/openglide" --prefix=/usr
make

now copy your dosbox freshly compiled executable located in dosbox/src in aim "Tomb Raider 1" folder.

3) modify dosboxTR.conf to be dosbox linux compatible
edit the file dosboxTR.conf located in the aim "Tomb Raider 1" folder and change this lines:
line 26, replace
output=direct3d
by
output=opengl
and
line 444, replace
imgmount d ".\game.dat" -t iso -fs iso
by
imgmount d "GAME.DAT" -t iso -fs iso
! be careful, linux dosbox is case sensitive in his config file !
you can now save and close the config file.

4) move the file "glide2x.ovl" located in aim "Tomb Raider 1" folder in the "TOMBRAID" folder.
Now open a terminal and go to your "Tomb raider 1" folder and launch your special dosbox version:
$ cd /home/your_login/.wine/...../Tomb Raider 1/
$ ./dosbox -conf dosboxTRLinux.conf

5) you can now launch Tomb Raider 1 in 3dfx mode on Linux but you have no music: your linux dosbox version does not know how to play mp3 files.
Workaround: go to the aim "Tomb Raider 1" folder and convert all the mp3 files in ogg format. To do this task I used the nautilus script "Audio files converter". now edit the file "game.dat" and replace all the ".mp3" reference to ".ogg".

Save and close the file, launch the game, you have now Tomb Raider 1 as you are on a dos machine with a 3DFX game, have a good game!!!

https://lh6.googleusercontent.com/-jIqe4LqzwNw/UEfH40nv_3I/AAAAAAAAAJ0/NLZVQEfIQWE/s641/Capture%2520du%25202012-09-05%252023%253A42%253A29.png

LGDN
Post edited September 06, 2012 by legluondunet
Thanks for this, I was wondering.

Are there any problems using openglide? (corruption, etc.)
Hi, thanks for find all this out, I also used your other guide for Tomb Raider 2 and 3 in Linux and it worked perfectly. However when I try this method, these commands
avatar
legluondunet: $ cvs -dserver:anonymous@openglide.cvs.sourceforge.net:/cvsroot/openglide login # push "enter" for password
$ cvs -z3 -dserver:anonymous@openglide.cvs.sourceforge.net:/cvsroot/openglide co -P
give me an error
cvs login: CVSROOT password specification is only valid for
cvs login: pserver connection method.
cvs [login aborted]: Bad CVSROOT: `server:anonymous@openglide.cvs.sourceforge.net:/cvsroot/openglide'.
OK I've found out why it didn't work, the first two lines are actually slightly wrong. It should be:

cvs -d:pserver:anonymous@openglide.cvs.sourceforge.net:/cvsroot/openglide login

then

cvs -z3 -d:pserver:anonymous@openglide.cvs.sourceforge.net:/cvsroot/openglide co -P openglide
I had the same error when following this guide, but there is only a one missing character in the first command. This is the correct one taken from the ubuntu-wiki:

cvs -d:pserver:anonymous@openglide.cvs.sourceforge.net:/cvsroot/openglide login

... and don't forget to install these packages at first: libsdl1.2-dev libsdl-sound1.2-dev libsdl-net1.2-dev libpcap-dev build-essential cvs autoconf libtool

OH, for any weird reason it didn't show me the already answered post to that, sorry.
Post edited April 04, 2017 by crataegus76
I just want to point out that the first two steps are no longer needed - recent versions of DOSBox now support Tomb Raider out of the box. So, it's just from part 3 onwards that is required.

TR 1 runs great for me in Linux.