It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I have a Skull Canyon with integrated IRIS PRO Graphics 580 and I am able to run TimeShift thanks to "3D Analyzer". I am not allowed to post a link to the file, but you should visit tommti-systems.de and grab version 2.36.

These are the settings that allowed me to launch and play the game flawlessly and without stuttering:

VendorID: 4318 (Geforce TI 4600)
DeviceID: 592 (same as above)
Performance: CHECK force windowed mode

That's it! If you don't check windowed mode, the game will launch with a black screen. I still have Hyper Threading enabled in my BIOS so it seems like the game has no problem with that.
Post edited November 15, 2017 by borowich
I tried this but sadly for me still getting the same effect.
Thanks for the suggestion, maybe one day I'll get this game running.
avatar
cloister56: I tried this but sadly for me still getting the same effect.
Thanks for the suggestion, maybe one day I'll get this game running.
Hyperthreading is only an issue for some CPU's if they are over 4 cored.

Like my 6 core CPU hyperthreaded from Intel..
I recently found a recommendation in some forum that suggested it was possible to get Sacred Gold to run without the severe graphics glitches by uninstalling the driver for the integrated GPU and installing a newer version. That did indeed work for Sacred.

When I recently reinstalled TimeShift (not the gog-version though) it now starts up normally and I haven't experienced any issues with the game. I have to assume that replacing the drivers for my integrated GPU did also solve my problems with TimeShift. Maybe it's helpful for somebody.
avatar
BurningSheep: I recently found a recommendation in some forum that suggested it was possible to get Sacred Gold to run without the severe graphics glitches by uninstalling the driver for the integrated GPU and installing a newer version. That did indeed work for Sacred.

When I recently reinstalled TimeShift (not the gog-version though) it now starts up normally and I haven't experienced any issues with the game. I have to assume that replacing the drivers for my integrated GPU did also solve my problems with TimeShift. Maybe it's helpful for somebody.
I hope it is too, I originally asked for a refund, but I just changed my mind, went & installed it on another machine, and then used a shortcut for this machine from the admin who responded to me. I am just glad I got it running at all and good luck to others.
Just disable multi threading and the game will work fine. I have a 6 core i7 and the game runs perfectly with multi threading turned off.