It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hey everyone,

I've got a problem when I'm trying to set my key bindings for Thief Gold. Just to clear everything, I'm playing on a clean install + Tfix, nothing else.

Basically, what I'm doing is replacing the usual WASD keys with the adapted ones for an AZERTY keyboard, being ZQSD. I'm using Shift to run, and Alt to Creep, with ZQSD just being the "normal speed" movement.

However, there's seems to be "default" keybindings on some key combos that I just can't override, even when I try editing the .bnd files. For example, there's one on [Alt + Q] which is "foot steps", another one on [Shift + Q] for flying (?), etc. As you can see, they're mostly on key combos you probably wouldn't use on a QWERTY settings, or at least not for moving.

This is a problem because with such bindings, I just cannot move slowly by using Creep (alt for me) to the left (Q for me) ; I just stop there, no movement at all. And that's just an example, there's other bindings like that, messing my setup overall. It's just clunky, sometimes I'll be able to creep to the left because I was already moving left before pressing Alt, but if ever release a key to stop a bit before moving again, it will not work.

Thus, my question is : What can I do to solve that ?

I've already tried quite a few solutions, to no avail so far :

- I've tried deleting those specific keybindings in the .bnd files, but it didn't work either. They seems to come back "by magic", I mean it's not there on the file, clearly, but the game still seems to have those key combos registered.

- I've tried putting my keyboard in QWERTY for the game, setting a US keyboard on Windows and using the ALT + SHIFT shortcut to switch to it while on the game. For some reasons, it just doesn't work and the game continue to see my keyboard as an AZERTY one.

- I've tried uncommenting the ext_kb_country_check line in the cam_ext.cfg file, but it did not change anything at all.

Oh and, related to this, I've got another "trouble" with the keybindings. Whenever I load a preset, some keys seems to keep their old bindings if the new one aren't overlaping them. For exemple, I'd map a key to "Drop Items", and load a profile with another key set to this function. Instead of replacing the binding for the action, it seems to add the key to it, which can make it quite a mess after a few load of presets, with actions having 3 or 4 different bindings to them. To top that off, I just for the life of me can't find a "empty all" button, so it's really annoying having to reset them all by hands.

So, if anyone could help me with that, I'd greatly appreciate it. I've searched quite a bit before creating this topic, and I've found nothing that worked so far, so forgive me if I missed something somewhere :/.
Post edited May 14, 2018 by Kitsue
No posts in this topic were marked as the solution yet. If you can help, add your reply
Hi there.
avatar
Kitsue: - I've tried deleting those specific keybindings in the .bnd files, but it didn't work either. They seems to come back "by magic", I mean it's not there on the file, clearly, but the game still seems to have those key combos registered.
So, I suppose you're editing the .bnd files under Saves, and not the user.bnd that sits in the same folder as Thief.exe?

That file has the "current" settings, so if you edit one of the ones under Saves, and since you mention that loading other bindings just adds keys and doesn't remove others, I suppose you'll have to completely overwrite user.bnd with a copy of the file you edited.
Post edited May 14, 2018 by Constance
Hey,

First of all, thanks for your answer !
You were right, I didn't even see there were bnd files in the root directory of the game ! And as you said, it does solve the problem with input being added instead of replaced, I created a nice and clean file thanks to that.

However, for reasons I still can't understand, and even if my current user.bnd file is totally clear of any unwanted bindings, there still appears to be some left.

Like, alt + Q / Shift + Q still seems to be there and still bothers my movement in the game ; I come back on those one often because they're the most jarring out of the bunch that gives me problem so far.

I've checked the file before and after launching the game, and while the file changes back to default if I ever go into the custom control screen, it stays exactly the same if I don't take a peak at all.

So, my user.bnd file is exactly as I want it, I launch the game, start a mission, problems are still there, I exit the game, check the file, and it's still the same as before.

Once again, am I missing out on something ?
Post edited May 14, 2018 by Kitsue