It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hey, everyone. I can't seem to run T:DS properly on my new MSI laptop (windows 10). I think I've tried everything I could think of and exhausted my google search options in effort of finding solution to this problem.

So the thing is, I've tried to run this game vanilla, but it doesn't support my resolution (1920x1080), so I tried a widescreen fix bundle (TF3FovPatch + t3weak + t3_widescreen). The game was then looking bareable, but just as I was finishing the tutorial, the game just froze at the moment you escape back to the streets (if I remember correctly, it should be a level change).

So I tried the Sneaky Upgrade and things got even more weird. Firstly, the game launched in windowed mode and after alt+entering back into fullscreen, I tried to change the resolution in game options, but it was stuck at 640x480 4:3 and the bar wouldn't even move.

I don't know what's causing this problem. I've even bought a separate copy of the game on Steam, but exact same problem occurs so it's not just GOG issue for sure. When I search around the internet for answers, it looks like only I have this weird problem and it pisses me off, 'cause I've just been doing an all ghost style Thief marathon and can't play this old gem again.

Help. plox ;(
No posts in this topic were marked as the solution yet. If you can help, add your reply