It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So i no what i am doing i played the game like 5 times ,but now it is not working
i used the moss and water ( those 2 work) and i throw the body nothing ,that part not working i tried 100 times ,nothing
even watched videos ,even if i no still watched them ,did the same thing nothing
now all the videos i seen they are old ,in the cave there are 2 alive ppl and monster ,but when i got there only monster in cave no ppl ( maybe changed over years) but not sure that is the problem
i cant find this bug on the entire internet ( google)
really dont no what to do any more ,tried everything :/
No posts in this topic were marked as the solution yet. If you can help, add your reply
I'd bring this over to the TTLG forum if I were you.
voodoo47: I'd bring this over to the TTLG forum if I were you.
i no ,but site not working any more :/
it will be up soon enough.
voodoo47: it will be up soon enough.
Fixed ,but thx for help :)
It appears some bodys are either bugged or not working on the tree . But in the end i found a body that worked
I played the game may times ,this is the first time this happened ,that is why it wa so strange
Post edited March 28, 2019 by miroslav87