It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I have all the thief games working without problems except for thief gold. I can get the game to run but none of the movies and cutscenes will run. I can go into the movies file, click on any and they will play. However, in the game none of them will. I know thief gold and thief 2 are similar but while they work in thief 2 they don't in thief gold. I have a laptop with both the nvidia and intel cards and have selected the nvidia card to run but no luck. I have tried everything I have seen suggested but without success. Any help would be appreciated.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Have you installed any of the unofficial patches? I think Tfix is the recommended one these days.
Thanks for your suggestion. I have done that. Tonight I figured it out. Windows Update required a restart, and apparently once that happened, everything worked properly and the game is working.