It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm at a loss as to what to try first. Here is my problem:
I run the game (have it set to run as administrator), and it loads the main menu but the graphics are locked up. I can hear the sound effects, and if I move the mouse (the cursor doesn't move), i can hear the menu option sound as if I was selecting them, but the graphics don't do anything (the gears on the side don't even move).

Any idea on what I should try to start with?

Hmm... I'm not sure... I think it may have something to do with my notebooks video system. The notebook has both an nvidia graphics processor, plus an integrated card that it can switch to either. I notice that even when I set the game to use the nvidia card, the indicator light on my keyboard seems to indicate that its running from the integrated card. It switches for a split second to the nvidia, but then goes back.
Post edited January 31, 2012 by celicynd
I had the same problem. Try out this post.
Yep, that seems to have worked. It appears the game is running fine now.