It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I reinstalled Thief Gold yesterday (steam version), I applied TFix and the Enhancement Pack 2.0. I reconfigured the controls, and so I used the shift key as a modifier to slow down the movement to be more stealthy. But then, I was surprised to see that when holding the shift key, I couldn't move left or peak right, that is that the Q and E keys wouldn't respond when holding that SHIFT key (I'm using an azerty keyboard).

So I looked for the solution and here it is :

Although I didn't set any particular control for "shift+q" and "shift+e" (shift is just a modifier key) in the redefine controls screen in the game, the game has some kind of invisible default hidden bindings by default. You have to quit the game, and open user.bnd in the game folder with a text editor, and look for these 2 lines :
bind q+shift "+fly 1"
bind e+shift "+fly -1"
Add a ; at the beginning of each of these 2 lines to disable them and save the file.

But that's not all, because the game also looks into a 2nd file to check the controls !!!

Open DEFAULT.BND too, and near the beginning of the file, check for these 2 lines :
game bind q+shift "+fly 1"
game bind e+shift "+fly -1"
Disable them with a ; too, save and quit the text editor, and now you're done. From now on, pressing shift+q and shift+e will respond in the game.
Omg thank you so much mate