It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So I installed TDS with Sneaky Upgrade, Minimalist Project, Gold etc. and when I start the first level, Garrett is autowalking. I don't have any other controller plugged into the PC, only mouse+keyboard.

Has anyone encountered this problem before and how to solve it?
Google search didn't help.
At the bottom of the Gamepad page in the tweak tool is a setting to ignore all controller input, which may be worth a try. (I had similar phantom input myself at one point, although it went away as spontaneously as it appeared...)
Please report back whether the setting helped in your case.
Sorry, but no, it doesn't help. By the description it looks like it is the fix for the problem.

It's perhaps possible that the tweak tool stores a wrong value in the config file?
Any idea which config file is that and its location?
You're right, there's a bug - not in the value, but the configuration key. If you know where your savegames are, look for a folder named Options next to one or more SaveGames* folders. Inside the Options folder, open SneakyOptions.ini and look for the [GamePad] section. Change a line there from "IgnoreAllInput=true" to "IgnoreAnalogInput=true".
If you change anything using the tweak tool after that, then the wrong key is written out again, I'm afraid. I'll fix it in the next version of the Sneaky Upgrade.

Edit: Looks like "IgnoreAllInput" is correct - buttons are ignored too. You can copy this fixed DLL into the System folder in the game install, the tweaker and the game should then agree on which key to use...
Post edited November 19, 2019 by snobel
Thanks a lot, it works for me with IgnoreAnalogInput and the old dll and with IgnoreAllInput and the new dll.

Thanks again and for doing the Sneaky Upgrade!