It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I recently upgraded to a new PC with a Ryzen 1700X CPU using base clock speed. Any time I pan the camera around while moving the game stutters pretty noticably. I am also getting severe stuttering at random when walking around and during cutscenes. I have tried playing at the lowest possible settings to see if that resolved the issue but it did not. I made sure that no other applications were running either aside from the game and the Galaxy client. I'm currently playing at 1080p resolution if that matters at all (I've heard of issues with Ryzen and 1080p?) Here are my specs:

Windows 10 Pro x64
NVIDIA GeForce GTX 1080 Ti
Corsair Vengeance 16GB DDR4
Ryzen 1700X @ 3.4GHz

Edit: I Apologize for the multiple reposts. My web browser was having a moment it seems.
Post edited October 25, 2017 by luxon00
This question / problem has been solved by Hickoryimage
avatar
luxon00: I made sure that no other applications were running either aside from the game and the Galaxy client.
Turn off the Galaxy overlay. There is a caveat on the store page about Windows 10 updates creating issues, and recently this came to fruition with an update interfering with the Galaxy client. Turning off the overlay seems to fix it for most people.
Post edited October 25, 2017 by Hickory
avatar
luxon00: I made sure that no other applications were running either aside from the game and the Galaxy client.
avatar
Hickory: Turn off the Galaxy overlay. There is a caveat on the store page about Windows 10 updates creating issues, and recently this came to fruition with an update interfering with the Galaxy client. Turning off the overlay seems to fix it for most people.
Yes, seems you were correct. I disabled the Galaxy overlay and now the stuttering has almost entirely vanished. Not at all surprised that this is a Windows 10 issue, and yet another of many reasons why I wish I had been able to stay with Win7 with this new PC. Thank you for your help.
avatar
Hickory: Turn off the Galaxy overlay. There is a caveat on the store page about Windows 10 updates creating issues, and recently this came to fruition with an update interfering with the Galaxy client. Turning off the overlay seems to fix it for most people.
avatar
luxon00: Yes, seems you were correct. I disabled the Galaxy overlay and now the stuttering has almost entirely vanished. Not at all surprised that this is a Windows 10 issue, and yet another of many reasons why I wish I had been able to stay with Win7 with this new PC. Thank you for your help.
I'm glad it's sorted for you. If you would spare the time to mark this question answered that would be great.