It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm playing on the GOTY edition, most achievements are fine but some like the 'Shrieker' and 'Woodland Spirit' contracts have not unlocked for me despite me killing both monsters.

I actually saved right before I finished the woodland quest to test this out, went back and completed it again using that save, still no achievement.

I know achievements aren't a big deal but it's something I enjoy collecting, anyone have this problem too?
No posts in this topic were marked as the solution yet. If you can help, add your reply
I got the same problem with "Woodland Spirit" achievement. I tried to do this quest many times in different ways and the achievement is still locked. Please, fix it.
Post edited January 16, 2018 by Bloodonice
One year later and these two still don't work for me.