It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
After Update 1.12 Mod Doesn't works

Hey. I have problem with mod SlotsSlotsSlots ( only with them) - after when I update game to 1.12 patch , when I start game , after compilation i have this error:

Error [content0]game\behavior_tree\tasks\monsters\bttaskmaintainsp eed.ws(10): Class 'CBTTaskMaintainSpeed' already defined.
Error [content0]game\behavior_tree\tasks\monsters\bttaskmaintainsp eed.ws(74): Class 'CBTTaskMaintainSpeedDef' already defined.
Error [content0]game\behavior_tree\tasks\reactions\bttaskisman.ws( 4): Class 'CBTCondIsMan' already defined.
Error [content0]game\behavior_tree\tasks\reactions\bttaskisman.ws( 15): Class 'CBTCondIsManDef' already defined.

I found solution on another forum:

Guy have the same code what I have. He advice to delete folder hacks from tasks - and everything should be fine, but when i do this i have another error :

Error [content0]game\player\r4player.ws(10134): To few params in call to function 'DisallowedActionDontShowHack'

This problem is only with mod SlotsSlotsSlots - i have 3 another mod from nexus mod but only with him i have such error. ( i download new wersion 2.3 for 1.12 patch from nexus mod but it work like i describe up)

Can someone tell me please what should I do?

Ps.
Sorry for title - my bad.
Post edited January 17, 2016 by Villgefortz444
avatar
Villgefortz444: Can someone tell me please what should I do?
You have incompatible mods installed. Remove them and wait for the author/s to update their mods.
How incompatible can be when is write in description under mod ( nexus mod):
- Released v2.3 for game version 1.12
avatar
Villgefortz444: How incompatible can be when is write in description under mod ( nexus mod):
- Released v2.3 for game version 1.12
Irrelevant. The script error is telling you it's incompatible with your game, regardless of what the author says.
I think I have something wrong - becouse on one forum guy said he download the same mod what i have and he don't have eny problem......
avatar
Villgefortz444: I think I have something wrong - becouse on one forum guy said he download the same mod what i have and he don't have eny problem......
Then you probably have remnants of another mod, or maybe extracted scripts that you've placed in the 'scripts' folder, which will also provoke this error message now that the game has been updated. You need to do some cleaning, and hope that you backed up your 'scripts' folder if you did place anything in there.